O wirusach komputerowych...

Rozprzestrzenianie się programów szkodliwych i wzrastająca liczba infekcji są ważnym wyzwaniem dla bezpieczeństwa każdego komputera. W tym opracowaniu możesz znaleźć przegląd programów złośliwych, ich funkcji i sposobów rozprzestrzeniania.
Ogólnie pojęcie 'wirus' oznacza program zagrażający danym przechowywanym na komputerze i/lub operacjom na nim wykonywanym. Podobnie do wirusa biologicznego, jego odmiana komputerowa może również powielać się oraz dołączać do plików wykonywalnych w celu rozprzestrzenienia. Kiedy zostanie odizolowany (na przykład w zarchiwizowanym pliku) i nie może być uruchomiony- możesz czuć się bezpiecznie, jest w takim przypadku nieszkodliwy. Lecz jeśli uwolni się z izolacji i uaktywni- może być niebezpieczny i dokonać znaczącej dewastacji systemu komputerowego.
Złośliwe programy nazywane potocznie 'wirusami' można podzielić na grupy, w zależności od ich aktywności i metody rozprzestrzeniania.
Tzw. boot-wirusy stanowiły dawniej największe zagrożenie. Próbują zainfekować sektory startowe (boot-sektory) odpowiedzialne za procesy uruchamiania. Aktywowane są już podczas startu i, jako że łatwo się rozprzestrzeniają, wymagają odpowiedniej uwagi.
Większość znanych dziś wirusów jest klasyfikowana jako wirusy programów. Zważywszy na ich liczebność wśród wszystkich znanych wirusów ich przodująca pozycja jest nie do przecenienia. Są to wirusy infekujące formaty DOSowe: .com, .exe oraz nowsze formaty .exe Windows: zarówno NE (New EXE) jak i PE (Portable EXE) .
Makrowirusy pojawiły się zaledwie parę lat temu, ale coraz mocniej wdzierają się w nasze życie. Ich główną ofiarą są dokumenty Microsoft Office wyposażone w makra. Dokumenty te często mogą być przesyłane poprzez email, co gwałtownie zwiększa ich rozprzestrzenianie.
Wirusy skryptowe - jak sama nazwa wskazuje- nie rozprzestrzeniają się w formie kodu binarnego, ale w postaci kodu źródłowego. Z tego powodu każdy może je łatwo modyfikować, produkując kolejne odmiany programów złośliwych.
Jednym z podtypów wirusów są tzw. robaki (worms). Wiele z nich rozprzestrzenia się poprzez e-mail lub próbuje wykorzystać możliwości rozprzetrzeniania w sieci komputerowej, używając podrobionego adresu nadawcy. Ze względy na czas potrzebny od obsługi takiej korespondencji, robaki mogą doprowadzać do blokowania systemów komputerowych.
Wraz ze wzrostem popularności Internetu rośnie stopniowo ilość wirusów mailowych i obecnie to one są na "szczycie popularności" wirusów. Rozprzestrzeniają się w e-mailach, niekiedy w tysiącach używanych programów czy serwerów pocztowych. Zainfekowane maile mogą być wykrywane poprzez badanie załącznika, będącego w istocie wirusem. Cykl życia współczesnych wirusów jest przyśpieszony. Typowy wirus mailowy rozprzestrzenia się najszybciej po jego wypuszczeniu, ale praktycznie zanika po krótkim czasie dzięki aktualizowanym i rozwijanym bazom antywirusowym.
Konie Trojańskie również należą do programów złośliwych. Nie są w stanie rozprzestrzeniać się bez pomocy, ale zawsze posiadają jakiś ukryty, szkodliwy algorytm wykorzystujący słabość systemu. Mimo, że nie rozprzestrzeniają się samodzielnie, możesz otrzymać je pocztą e-mail lub pobrać z Internetu. Jest wiele programów trojańskich opartych na tej zasadzie.
Wirusy typu backdoor otwierają "tylnie drzwi" zaatakowanego komputera umożliwiając łatwy dostęp do systemu.
Dialery zmieniają internetowe połączenia dial-up. Łączą się ze zdalnym dostawcą Internetu, zamiast lokalnego, powiekszając rachunki telefoniczne.
Programy przechwytujące hasła próbują zbierać zakodowane pliki użytkownika oraz hasła odnalezione w pamięci i wysyłać na określony adres e-mail.
Jak widzisz ochrona jest uzasadniona wobec częstości i różnorodności obecnych wirusów. W zakresie bezpieczeństwa komputerowego użycie aplikacji antywirusowych nie rodzi już żadnych wątpliwości.


Objawy zakażenia wirusami

Objawy infekcji mocno zależą od własności wirusa. Poniższa lista zawiera parę ogólnych symptomów, jakie możesz zauważyć:
• Różne problemy na komputerze (np. problem z kopiowaniem plików)
• Komputer często się zawiesza lub restartuje
• Otrzymujesz komunikaty od odbiorców, że odbierają zainfekowane maile od Ciebie
• Komputer działa wolniej, niż zazwyczaj
• Mniej dostępnej pamięci, niż przedtem
• Znikają elementy menu, funkcje lub całe aplikacje
• Otwieranie programów zabiera więcej czasu niż przedtem, choć konfigaracja była niezmieniona
• Wzrasta widocznie wielkość plików bez wyraźnego powodu
• Niektóre wirusy po prostu wyświetlają okno informujące o zakażeniu
• Zmienia się bez powodu data plików
• Brak dostępu do sterowników
• Na ekranie wyświetlane są dziwne formy graficzne


Uwolnij komputer od wirusów

Codziennie wiele wirusów na świecie rozpoczyna swoją szkodliwą działalność, uruchamiając ataki przeciwko użytkownikom i rozwiązaniom antywirusowym z wzrastającą siłą. Z powodu szybkiego rozprzestrzeniania są w stanie zainfekować podejrzane komputery w ciągu chwili.
Wysiłek poświęcony na odpowiednie zabezpieczenie szybko się zwraca, uprzedzając wiele poważnych ataków. Pamiętaj, że pilnując wymogów bezpieczeństwa zapobiegasz utracie danych lub innym poważnym problemom. Oto kilka pomysłów, jak można uwolnić komputer od wirusów:
• Skanuj antywirusowo dane pobrane do systemu z nośników zewnętrznych.
• Używaj rezydentnej ochrony antywirusowej.
• Aktualizuj bazę oprogramowania antywirusowego tak często, jak jest to możliwe.
• Pliki załączone do korespondencji traktuj z rezerwą, jak potencjalne niebezpieczeństwo.
• Ustaw użytkownikom zróżnicowane poziomy autoryzacji.
• Ważny jest sposób obsługi zasobów współdzielonych! Zapewnij odpowiednie prawa dostępu i ograniczenia dla różnych użytkowników.
• Używaj tylko dozwolonych aplikacji.
• Używaj zapór ogniowych przeciwko atakom z zewnątrz.
• Pobieraj pliki z wiarygodnych źródeł.
• Pilnuj swoich haseł.
• W przypadku wystąpienia symptomów infekcji - skanuj antywirusowo cały system.
• Nie udostępniaj nikomu swoich ważnych danych na komputerze.
Użytkownicy mogą sami się chronić przeciwko wirusom używając wiarygodnych i aktualnych aplikacji antywirusowych.


Motor skanujący VirusBuster

Wszystkie nasze produkty są oparte o motor skanujący VirusBuster posiadający szczególne osiągi. Do wykrywania szkodliwych programów używa się również metod heurystycznych. Dzięki takiej swojej formule oraz metodom skanowania niezależnym od systemu operacyjnego może on wydajnie skanować na obecność wszystkich znanych wirusów, robaków, trojanów, skryptów, makrowirusów i innych szkodliwych kodów w każdym systemie, a nawet w plikach skompresowanych. Do przeprowadzenia tego typu skanowania motor skanujący używa techniki emulacji.
Najważniejsze własności:
• Analiza heurystyczna
• Szybkie skanowanie
• W miarę możliwości emulacja PC/ procesora
• Niezależność platformowa w 99% (pozostały 1% jest implementacją zależną od platformy systemowej)
• Elastyczna architektura bazy antywirusowej: możliwość dodania dowolnych nowych typów plików
• Użycie niezależnych technologii skanowania
• Codzienna aktualizacja bazy antywirusowej
• Technologia motora skanującego i baza antywirusowa niezależna od platformy systemowej/ procesora
• Recongizer i parser niezależne od typu plików
• Natywne skanowanie w archiwach .tar, .gz, .bzip2, .zip, .rar, .arj, .ace, .chm, TNEF, ms cab oraz plikach cab powłoki instalacyjnej
• Natywne skanowanie w plikach kompresowanych z diet, upx, aspack, pecompact oraz fsg (inne pliki spakowane do .exe za pomocą technologii emulacji)
• Skanowanie w archiwach zagnieżdżonych do dowolnego poziomu (zależne od zasobów systemowych)
• Skanowanie na obecnośc wirusów, robaków, trojanów i innych kodów szkodliwych
• Detekcja i usuwanie programów szpiegujących (spywares) i reklamowych (adwares)
• Informacja o robakach serwerowych (IWORMs) usuwalnych wraz całą pocztą
• Skanowanie w wielu plikach wykonywalnych
• Skanowanie w plikach Microsoft Word, Excel, PowerPoint, Access i MS Project.
• Skanowanie w obiektach wbudowanych OLE
• Skanowanie w formacie XML nowego Office 2003
• Skanowanie w plikach HTML, Java script, ActiveX i Visual Basic Script (VBS)
• Skanowanie w innych plikach języków skryptowych, jak skrypty powłoki Unix / Linux
• Skanowanie w plikach Help Windows (HLP)
• Skanowanie w plikach LNK i PIF
• Wbudowany parser MIME do skanowania poczty e-mail, skrzynek i plików MHT
• Obsługa następujących metod enkodowania: BinHex 4.0, Base64, Quoted-printable, UUEncode
• Skanowanie natywne w skrzynkach Outlook Express


VIRUSBUSTER PROFESSIONAL 2006

Ilość wirusów i innych zagrożeń, docierających z Internetu z dnia na dzień gwałtownie wzrasta, dlatego też istotna jest skuteczna ochrona użytkowników indywidualnych i korporacyjnych. Możliwa infekcja może nie tylko powodować straty danych, ale czas i pieniądze strwonione na ich odzyskanie może być poważną stratą dla firmy i użytkowników.

VirusBuster Professional zapewnia wszechstronną ochronę dla każdej stacji. Poza rezydentną ochroną plików, chroni codzienną pracę i korespondencję poprzez zintegrowanie z aplikacjami Microsoft Office oraz wykrywa, usuwa wszystkie szkodliwe programy docierające z Internetu podczas przeglądania i obsługi poczty.

Zintegrowany moduł Office w VirusBuster Professional jest wtyczką ochronną, która skanuje dokumenty i notatki po dekodowaniu, ale przed wykonaniem w ramach aplikacji MS Office (Word, Excel, PowerPoint, Outlook, Access). Podczas użycia Professional, zakodowane dokumenty lub korespondencja mogą być jedynie przegladane przez nadawcę i odbiorcę, nie ma centralnego zbierania danych, dekodowania lub skanowania w zgodzie z ochroną Twojej prywatności.
Najważniejsze własności:
• Skuteczna ochrona Twojego komputera przed wirusami
• Prostota użycia, interfejs w stylu kreatora
• Zaawansowany interfejs dla doświadczonych użytkowników
• Działanie zadaniowe
• Przyrostowa aktualizacja bazy danych sygnatu
• Skanowanie uruchamiane manualnie lub wg harmonogramu
• Ochrona rezydentna z predefiniowanymi poziomami ochrony
• Zadaniowe, modularne aktualizacje
• Kwarantanna inteligentna plików zainfekowanych
• Ochrona rezydentna zintegrowana z aplikacjami MS Office dla ochrony codziennej pracy
• Ochrona e-mail zintegrowana z MS Outlook
• Obsługa Windows Security Center


Usuń, zmodyfikuj, napraw

Jeśli chcesz usunąć VirusBuster ze swojego komputera, lub zmodyfikować zainstalowane komponenty, albo ponownie zainstalować zainstalowane już komponenty, należy wykonać poniższe operacje:
• Kliknij na ikonę Dodaj lub usuń programy (Add/remove program) w Panelu sterowania (Control panel)!
• Znajdź produkt, który chcesz usunąć na liście i zaznacz go.
• Kliknij na przycisk |Zmień/usuń| (Modify/remove)!
W oknie, które się wyświetli, możesz wybrać żądaną operację:
• Zmień (Modify)
Jeśli wybierzesz tę opcję, po kliknięciu na przycisk |Dalej >| (Next >) pojawi się lista komponentów. Wybierając lub odznaczając komponenty z listy możesz dodać nowe komponenty lub usunąć już zainstalowane. Żądana operacja (instalacja/usunięcie) zostanie przeprowadzona po kliknięciu na przycisk Dalej (Next).
• Napraw (Repair)
Ponownie instaluje już zainstalowane komponenty.
• Usuń (Remove)
Usuwa wszystkie zainstalowane komponenty z komputera.


Uruchamianie z Menu startowego

W trakcie instalacji produkty VirusBuster zostaną zarejestrowane w menu Start / Programy / VirusBuster (Start / Programs / VirusBuster). Tu umieszczone są wszystkie związane z produktem skróty, stąd można uruchomić oprogramowanie, z tego menu można otworzyć wszelkie dokumenty związane z tym produktem.
Program można uruchomić przy pomocy poniższego skrótu:
• Konsola VirusBuster 2006 (VirusBuster 2006 Console)
Uruchamia on ogólny, kompleksowy, graficzny interfejs użytkownika typu Kreator (Wizard), który umożliwia dostęp do zainstalowanych komponentów.
Uwaga!
W przypadku instalacji kilku różnych produktów VirusBuster, skrót ten umożliwia jednoczesne uruchomienie poszczególnych produktów.

Istnieją skróty dla dokumentacji (Pomoc) (Help), które zawierają szczegółowe informacje o korzystaniu z produktów i o ich działaniu.

Zainstalowane komponenty i funkcje można kontrolować nie tylko za pośrednictwem kompleksowego interfejsu, można je także uruchamiać indywidualnie, z katalogu Komponenty VirusBuster (VirusBuster Components), jeśli nie jest uruchomiona konsola VirusBuster. Jeśli jeden z komponentów nie został uruchomiony z konsoli, dostęp do niego z konsoli nie jest możliwy dopóki nie zostanie on zatrzymany.


Pasek zadań (System tray)

Możliwy jest dostęp do VirusBuster’a z paska zadań. Po instalacji VirusBuster’a na paska zadań pojawi się jego ikona, sygnalizując, że produkt VirusBuster jest obecny w systemie.
Mała tarcza przedstawiona na ikonie oznacza status ochrony (Shield) (Ochrony rezydentnej), która zapewnia systemowi stałą ochronę przed wirusami (jeśli funkcja ta nie jest zainstalowana, tarcza nie jest wyświetlana). Kolor tarczy oznacza status ochrony:
• Zielony
Tarcza jest aktywna, komputer jest chroniony przed wirusami (jeśli produkt jest zarejestrowany lub jeśli jest to jego okres próbny).
• Szary
Tarcza nie działa, nie ma rezydentnej ochrony przed wirusami.
Dostęp do najważniejszych funkcji programu można z łatwością uzyskać z Paska Zadań, właśnie stąd można uruchomić najczęściej używane komponenty i zadania. Poprzez kliknięcie na ikonę VirusBuster (1) prawym klawiszem myszy, można otworzyć menu lokalne, z którego można wybrać żądaną funkcję. Jeśli menu posiada pod-menu, będzie ono oznaczone małą strzałką przed nazwą pozycji menu głównego (2).
Następujące pozycje zawsze pojawiają się w menu:
• Rejestracja (Registration)
Ta pozycja menu zawiera wszystkie funkcje związane z zakupem i rejestracją oprogramowania. Szczegółowe informacje na ten temat znajdziesz w części zatytułowanej Zakup, rejestracja, aktywacja.
• Wsparcie (Suport)
Ta pozycja menu zawiera trzy następujące punkty/pozycje:
Pomoc (Help)
Stąd można uzyskać dostęp do dokumentacji zainstalowanych produktów.
Skontaktuj się z nami (Contact us)
Przy pomocy tej funkcji możesz wysłać wiadomość e-mail do firmy VirusBuster o tym produkcie, pod warunkiem, ze zainstalowany jest komponent Mailer (szczegółowy opis znajduje się w części zatytułowanej Wysyłanie wiadomości).
Informacje (Information)
Otwiera stronę główną VirusBuster’a.

Po zarejestrowaniu oprogramowania lub podczas okresu próbnego dostęp do najważniejszych zainstalowanych komponentów oraz do dostępnych zadań skanowania lub aktualizacji można uzyskać z menu programu. Konsolę VirusBuster’a można uruchomić klikając dwukrotnie na menu lewym klawiszem myszy.


Okienka wyskakujące (pop-up)

Dzięki małym okienkom informacyjnym – tzw. okienkom wyskakującym – pojawiającym się nad Paskiem Zadań, użytkownicy szybko uzyskują aktualne informacje o statusie systemu antywirusowego oraz o zdarzeniach zachodzących podczas działania programu.
Tytuł wyróżniony pogrubioną czcionką oznacza „nadawcę” wyświetlonego komunikatu. Komunikat informuje użytkowników o działaniu danego modułu, lub zawiera komunikat z danego modułu. W niektórych przypadkach pomiędzy liniami komunikatu pojawia się przycisk. Kliknięcie na przycisk umożliwia użytkownikom bezpośrednie przejście do oferowanej funkcji (np. w przypadku, gdy komunikat zawiera ostrzeżenie dla użytkownika związane z aktualizacją bazy danych wirusów, kliknięcie na przycisk |Aktualizuj| (Update) umożliwia natychmiastowe rozpoczęcie aktualizacji).

Po chwili okno wyskakujące zamyka się samoczynnie, może także zostać zamknięte przez użytkownika kliknięciem na przycisk |X|, znajdujący się w prawym górnym rogu okna.


Zakup, rejestracja, aktywacja

Po pierwszej instalacji można w pełni korzystać z zainstalowanego oprogramowania antywirusowego przez 30 dni. Podczas tego ‘Okresu próbnego’ użytkownik ma dostęp do wszystkich funkcji i ustawień, działają wszystkie funkcje usuwania wirusów. W tym czasie oprogramowanie stanowi w pełni funkcjonalną ochronę antywirusową. Jedyna różnica pomiędzy wersją zarejestrowaną i próbną wynika z faktu, iż wersja próbna regularnie powiadamia użytkownika wyświetlając wiadomość w okienku komunikatów (podczas uruchamiania komponentów programu), że jest to okres próbny, oraz że oprogramowanie można zarejestrować na kilka różnych sposobów. Udostępnionych jest kilka opcji: produkt można zakupić, zarejestrować lub aktywować, albo – tylko w trakcie trwania okresu próbnego – można użyć przycisku |Kontynuuj| (Continue) w celu uruchomienia programu (i opóźnienia zakupu, rejestracji i aktywacji). Przycisk |Exit| (Exit) zamknie program.

Zakup

Funkcja zakupu jest dostępna w oknie wyskakującym - należy kliknąć na przycisk |Kup ...| (Buy). Program przekieruje użytkownika na stronę główną VirusBuster’a, z której można zakupić produkt online – poprzez złożenia zamówienia na licencję e-mailem – użytkownik otrzyma dane do rejestracji, które należy wykorzystać w celu zarejestrowania produktu.

Rejestracja

Po instalacji można w pełni korzystać z produktu przez 30 dni, jest to okres próbny. Po upływie tego czasu nie jest możliwe dalsze korzystanie z oprogramowania, jeśli nie zostanie ono zarejestrowane przy użyciu ważnego klucza rejestracyjnego. Panel, z którego można zarejestrować program, można otworzyć kliknięciem na przycisk |Rejestruj ...| (Register) w oknie wyskakującym, lub otwierając tę funkcję z menu ikony VirusBuster’a znajdującej się na Pasku Zadań.

Produkt do rejestracji można wybrać na panelu rejestracyjnym z menu Nazwa produktu: (Product’s name:) (na jednym komputerze można jednocześnie instalować kilka produktów). Dane do rejestracji należy wpisać w polach Nazwa użytkownika: (User name:) oraz Klucz rejestracji: (Registration key:). Następnie, aby zarejestrować oprogramowanie, należy kliknąć przycisk |Rejestruj| (Register). Jeśli wprowadzono ważne dane do rejestracji na panelu wyświetli się termin ważności rejestracji. Pojawi się również zielona linia z napisem Zarejestrowany (Registered).
Po upływie ważności rejestracji można w pełni korzystać z produktu do momentu następnej aktualizacji oprogramowania. Zgodnie z umową licencyjną produktu prawo do korzystania z aktualizacji jest ważne dopóki ważna jest licencja! Zgodnie z powyższym, po upływie ważności rejestracji, aktualizacji produktu można dokonać jedynie po wykupieniu nowej licencji i ponownym zarejestrowaniu oprogramowania. Jeśli nie wykupiono nowej licencji i nie dokonano ponownej rejestracji aktualizacja spowoduje zaprzestanie działania produktu. Powyższe zasady nie dotyczą bazy danych wirusów, której aktualizację można przeprowadzać bez ograniczeń, jednak producent nie gwarantuje zgodności oprogramowania z bazą pochodzącą z nowych aktualizacji.

Aktywacja

W trakcie procesu aktywacji użytkownik może, przy pomocy klucza aktywacji (3x4 znaki), poprosić online o klucz rejestracji produktu (3x5 znaków). Aktywacja nie jest równoznaczna z rejestracją, jest procesem prowadzącym do uzyskania klucza rejestracji. Okres rejestracji rozpoczyna się w dniu aktywacji i trwa do momentu ustalonego w umowie licencyjnej.
Dostęp do panelu aktywacji można uzyskać z okna wyskakującego poprzez kliknięcie na przycisk |Aktywuj ...| (Activate).


Interfejs użytkownika

Dzięki temu, iż wygląd produktów VirusBuster jest ujednolicony, to posiadają one kompleksowy interfejs użytkownika pozwalający na kontrolę wszystkich programów. Zainstalowane produkty można uruchomić przy pomocy tej samej ikony programu (Uruchamianie z menu Start), wszystkie zainstalowane komponenty są dostępne na jednym interfejsie użytkownika.
Uwaga!
Jeśli użytkownik logujący się do systemu nie posiada uprawnień administratora (użytkownik niskiego poziomu) większość ustawień na interfejsie użytkownika nie będzie dla niego dostępna!
Produkty VirusBuster są wyposażone w interfejs użytkownika typu kreator, dziek któremu użytkownik może z łatwością modyfikować ustawienia produktu. Ustawienia funkcji można modyfikować „krok po kroku” z pomocą szczegółowego opisu znajdującego się na panelu każdego z ustawień.
Ustawienia komponentów ochronnych znajdujących się na interfejsie typu kreator można zmodyfikować na następujących dwóch poziomach:
• Prosty interfejs użytkownika
Jest to interfejs przeznaczony dla początkujących użytkowników. Umieszczono na nim tylko podstawowe ustawienia, pozwala on zmodyfikować wyłącznie najważniejsze parametry. Ochronę można dopasować do potrzeb użytkownika przy pomocy predefiniowanych kombinacji ustawień.
• Zaawansowany interfejs użytkownika
Jest to interfejs przeznaczony dla doświadczonych użytkowników. Na tym interfejsie dostępne są wszystkie ustawienia, system może zostać w pełni dostosowany do osobistych potrzeb.
Przy pomocy przycisków |Proste| (Simple) – |Zaawansowane| (Advanced) znajdujących się na dole każdego z paneli ustawień można przechodzić z jednego interfejsu do drugiego.
Uwaga!
Przy przełączaniu się z Zaawansowanego panelu użytkownika na Prosty, może okazać się, że niektóre ustawienia nie są kojarzone z żadnymi kombinacjami ustawień na prostym interfejsie. W takim przypadku – jeśli dojdzie do przełączenia – wszystkie ustawienia zmodyfikowane na zaawansowanym interfejsie zostaną utracone i będą zastąpione kombinacją ustawień, która może zostać wyświetlona na interfejsie prostym.

Struktura interfejsu

Interfejs użytkownika VirusBuster’a można wyświetlić uruchamiając go z menu Start przy pomocy skrótu Konsola VirusBuster’a (VirusBuster Console). Poprzez ten interfejs można, przy pomocy menu i paneli, modyfikować wybrane ustawienia, uruchamiać skanowanie antywirusowe, wysyłać wiadomości, itp.
Po uruchomieniu konsoli pojawi się Strona główna zawierająca podstawowe informacje o programie. Tu możesz sprawdzić status i numery wersji zainstalowanych produktów VirusBuster’a oraz najważniejsze komponenty. Aktualizację bazy danych wirusów można uruchomić kliknięciem na przycisk |Aktualizuj| (Update). Możesz sprawdzić status Tarczy oraz wersję bazy danych wirusów. Ikony i ich znaczenie:
Usługa aktywna / W przypadku bazy danych wirusów: baza danych ma mniej niż 7 dni, jest aktualna.
Usługa zatrzymana / W przypadku bazy danych wirusów: baza danych ma więcej niż 7 dni.
Usługa nie jest zainstalowana / W przypadku bazy danych wirusów: błąd w bazie danych wirusów.
Możesz sprawdzić ustawienia każdego z komponentów przy pomocy menu (3) znajdujących się na konsoli. Po kliknięciu na jedno z menu, na panelu ustawień (6) zostaną wyświetlone opcje i ustawienia komponentu. Wtedy w menu (3) zostaną wyświetlone pod-menu wybranego komponentu, korzystając z nich uzyskasz dostęp do innych funkcji i ustawień komponentu lub będziesz w stanie zobaczyć, na którym etapie, wieloetapowego procesu definiowania ustawień znajdujesz się w danej chwili. Możesz powrócić na Stronę główną klikając na jej ikonę w panelu nawigacji (2). Dostęp do każdego z etapów nawigacji można uzyskać przy pomocy strzałek (w prawo – w lewo).
Kreator interfejsu użytkownika
Struktura interfejsu:
1 Nagłówek
Nagłówek okna, logo VirusBuster’a.
2 Panel nawigacyjny
Nawigacja poprzez wybrane elementy menu i panele. Dostęp do uprzednio oglądanego panelu/paneli oraz menu możesz uzyskać przy pomocy strzałki skierowanej w lewą stronę, zaś powrót do poprzedniego kroku, z którego się cofnąłeś – przy pomocy strzałki skierowanej w prawo. Dostęp do strony głównej możesz uzyskać klikając na jej ikonę. Symbol kłódki informuje czy zmiana głównych opcji jest możliwa, czy nie (Administracja).
3 Menu
Poprzez elementy menu możesz uzyskać dostęp do paneli ustawień zainstalowanych komponentów.
4 Wyjście
Klikając na przycisk |Exit| (Exit) możesz w każdej chwili wyjść z programu.
5 Przyciski kontrolne panelu
Na większości paneli ustawień znajduje się kilka przycisków wspomagających proces definiowania ustawień lub uruchamiających ten proces, przy ich pomocy możesz przechodzić z prostego do zaawansowanego interfejsu użytkownika, przejść przez proces definiowania ustawień lub uruchomić wybrane zadanie.
6 Panel ustawień
Tu wyświetla się panel ustawień komponentu, opcji, lub operacji, która została wybrana w menu (3). Jest to panel, na którym można zmodyfikować ustawienia, a także dodać lub uruchomić zadania.
7 Pomoc
Tu możesz wyświetlić tekst pomocy dotyczącej ustawień na aktywnym panelu.

Przłączenie do kompaktowego interfejsu użytkownika

Jeśli produkt jest uruchamiany na monitorze o niskiej rozdzielczości, niektóre panele mogą być niewidzoczne, ponieważ nie jest wyświetlane całe okno aplikacji. Mogą być niewidoczne niektóre elementy menu lub opcje. W takich przypadkach zalecane jest przełączenie do trybu widoku kompaktowego VirusBuster za pomocą przycisku widocznego w prawym górnym rogu interfejsu użytkownika. Aby powrócić do normalnego trybu, kliknij na sam przycisk ponownie.
Uwaga!
Jeśli rozdzielczość wynosi 640X480 pikseli, dostępny jest tylko interfejs kompaktowy. W takim przypadku przycisk nie jest pokazywany.

W interfejsie kompaktowym menu pokazywane jest po lewej stronie, dla zaoszczędzenia miejsca. Kliknij na pasek boczny, który widzisz po lewej stronie, zamiast zwyczajowego miejsca, aby otworzyć potrzebny panel. Jest to panel przesuwalny. Po wyborze żądanego modułu możesz go ukryć klikając ponownie na pasek.


Jak przetestować silnik skanowania wirusów

Aby zobaczyć co się dzieje gdy silnik skanowania wirusów napotyka zainfekowany plik, możesz użyć pliku Standardowego Testu Antywirusowego EICAR (European Institute of Computer Anti-virus Research), który oczywiście nie jest wirusem, ale jest wykrywany przez nasz silnik jako wirus. Aby stworzyć plik zawierający ciąg znaków EICAR, wpisz następujące znaki do pliku tekstowego a następnie zachowaj go nadając mu rozszerzenie .COM (np. EICAR.COM):
X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*
By sprawdzić działanie silnika skanowania wirusów, przeprowadź skanowanie na tym nowoutworzonym pliku, lub - w przypadku, gdy ochrona rezydentna (Tarcza) jest aktywna - uruchom ten plik (jako program). Jeśli silnik działa poprawnie, w wyniku skanowania lub uruchomienia pojawi się komunikat z ostrzeżeniem.
Uwaga!
Jeśli plik ten zostanie uruchomiony jako program, wyświetli on napis "EICAR-STANDARD-ANTIVIRUS-TEST-FILE", i zakończy działanie.


Struktura ochrony antywirusowej

Produkty VirusBuster składają się z modułów, komponenty programu razem stanowią ochronę antywirusową. Na następnych stronach omówimy działanie i strukturę każdego z komponentów.


Tarcza (Shield)

Komponent ten zapewnia ochronę rezydentną przed wirusami. Jego głównym zadaniem jest skanowanie antywirusowe, oraz ich usuwanie w tle. Komponent skanuje pliki, gdy dostęp do nich jest otwarty (w trakcie pisania lub odczytywania pliku). Ustawienia Tarczy można zmodyfikować na następujących panelach:
• Ustawienia (Settings)
• Obszary skanowania (Scan areas)
• Statystyki (Statistics)

Ustawienia (Settings)

Ustawienia ochrony można zmodyfikować na panelu Ustawienia (Settings). Ochronę można błyskawicznie skonfigurować na prostym interfejsie użytkownika, szczegółową konfigurację można przeprowadzić na panelu Zaawansowanym, który można wyświetlić klikając na przycisk |Zaawansowane| (Advanced).

Ustawienia proste

Ochrona staje się aktywna po wybraniu opcji Aktywna (Active). Poziom ochrony można z łatwością ustawić wybierając spośród poziomów predefiniowanych na panelu. Poziomy ochrony to kombinacja ustawień, które można wyświetlić przechodząc do panelu Zaawansowanego (Advanced).
Poziomy ochrony i ich ustawienia:
• Wysoki (High)
Korzysta z opcji Pełnego (Full) skanowania wirusów, wysoka heurystyka, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną poddane kwarantannie.
• Średni (Medium)
Korzysta z opcji Rozległego (Extensive) skanowania wirusów, średnia heurystyka, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną pominięte.
• Niski (Weak)
Korzysta z opcji Szybkiego (Quick) skanowania pod kątem wirusów, brak heurystyki, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną pominięte.
• Ustawienia własne (Custom settings)
Wybranie tej opcji nie jest możliwe, zostanie ona włączona, jeśli na panelu Zaawansowanym (Advanced) zostanie stworzona kombinacja ustawień, która nie istnieje na żadnym z predefiniowanych poziomów.

Ustawienia zaawansowane (Advanced settings)

Ochronę można aktywować wybierając opcję Włącz Tarczę (Enable Shield) na panelu Zaawansowanym (Advanced).

Po włączeniu opcji Wyświetlaj ostrzeżenia (Display warnings), w przypadku wykrycia wirusa użytkownik otrzyma komunikat ostrzegawczy. Jeśli funkcja ta jest wyłączona, program wykona wybrane operacje, jednak użytkownik nie otrzyma żadnych komunikatów a program dokona jedynie wpisów w dzienniku.
Metodę skanowania można ustawić na jeden z następujących poziomów:
• Szybkie/Rozległe/Pełne ( Quick/Extensive/Full )
Analizę heurystyczną można ustawić na jeden z następujących poziomów:
• Wyłączona/Normalna/Silna ( Disabled/Normal/Strong )

Opis ustawień W przypadku wykrycia wirusa znajdziesz w części zatytułowanej Skaner.
W przypadku znalezienia wirusa dostępne są następujące operacje:
• Zniszcz/Pomiń/Przemianuj/Poddaj kwarantannie/Usuń (Kill/Skip/Rename/Move to quarantine/Delete)
W przypadku wykrycia wirusa w wyniku analizy heurystycznej możliwe są następujące działania drugorzędne:
• Pomiń/Przemianuj/Poddaj kwarantannie/Usuń (Skip/Rename/Move to quarantine/Delete)

Obszary skanowania (Scan areas)

Na tym panelu można określić rodzaje plików, które mają zostać poddane skanowaniu, oraz katalogi, które nie będą skanowane.

Jeśli opcja Skanuj wszystkie pliki (Scan all files) jest włączona, wszystkie rodzaje plików (o dowolnych rozszerzeniach) zostaną poddane skanowaniu (w chwili, gdy nastąpi próba dostępu do nich).

Jeśli włączona jest opcja Skanuj określone rodzaje plików (Scan specified file types), skanowaniu zostaną poddane tylko określone rodzaje plików, o określonych rozszerzeniach, gdy nastąpi próba dostępu do nich. Rozszerzenia można ustawić w części Ustawienia rozszerzeń znajdującej się w komponencie Skaner.

W oknie Ścieżki wykluczone (Excluded paths) wyświetla się drzewko napędów i katalogów komputera. Użytkownik może wybrać katalogi, które nie będą chronione, pliki w tych katalogach nie będą skanowane w chwili, gdy nastąpi próba dostępu do nich. Znak plus informuje czy dany katalog posiada podkatalogi. Znak plus zostanie zastąpiony minusem, gdy katalog zostanie otwarty, a jego podkatalogi wyświetlone. Katalog można otworzyć pojedynczym kliknięciem na jego nazwę lub na znak plus. Po zaznaczeniu okienka wyboru znajdującego się przed nazwą katalogu pliki tego katalogu nie będą poddawane skanowaniu. Przy zaznaczaniu okienek wyboru katalogu bardzo ważny jest jego status (otwarty – zamknięty), gdy katalog jest otwarty jego podkatalogi będą poddawane skanowaniu. Jeśli katalog jest zamknięty, zaznaczenie okna wyboru zostanie zastosowane rekursywnie do wszystkich podkatalogów. Katalogi, które zostały wybrane rekursywnie są zaznaczone gwiazdką (*).

Jeśli twój komputer stanowi część sieci, do listy katalogów wykluczonych możesz dodać dzielone zasoby sieciowe klikając na przycisk |Sieć...| (Network...). Należy wybrać żądany katalog w wyświetlonym oknie, a następnie kliknąć na przycisk |Dodaj| (Add). Wybrana ścieżka zostanie dodana do już istniejących.
Istnieją trzy sposoby wybrania katalogu:
• Zaznaczenie okienka wyboru katalogu
Katalog i wszystkie jego podkatalogi zostają wybrane, znajdujące się w nich pliki nie będą skanowane, gdy nastąpi próba dostępu do nich.
• Okienko wyboru katalogu nie jest zaznaczone, nazwa katalogu jest wyróżniona pogrubioną czcionką.
W katalogu znajduje się podkatalog, który jest zaznaczony. Pliki tego katalogu nie będą skanowane, gdy nastąpi próba dostępu do nich.
• Okienko wyboru katalogu nie jest zaznaczone, nazwa katalogu nie jest napisana pogrubioną czcionką. Ani katalog, ani żaden z jego podkatalogów nie jest zaznaczony, wszystkie pliki tego katalogu będą skanowane, gdy nastąpi próba dostępu do nich.

Statystyki (Statistics)

Panel ten pokazuje szczegółowe informacje o plikach skanowanych przez Tarczę oraz o wykrytych wirusach. Na panelu wyświetla się także nazwa ostatniego wykrytego wirusa oraz ścieżka, w której został on wykryty.


Filtr zawartości (Content filter)

Funkcja filtrowania zawartości, w którą wyposażony jest VirusBuster zapewnia klientom ochronę przed złośliwymi programami pochodzącymi z Internetu. Komponenty filtrujące zawartość analizują komunikację w sieci i skanują przepływ danych przy użyciu znanych sobie protokołów.
Uwaga!
W przypadku niżej wymienionych protokołów możesz używać Filtru zawartości z ograniczeniami:
Protokół IMAP: Filtr zawartości nie działa w przypadku klientów, którzy dokonują podziału zawartości i pobierają wiadomość pocztową w kilku częściach. Komunikacja wielowątkowa również nie jest obsługiwana (np. The Bat!).
Protokół HTTP: Filtr zawartości nie skanuje wirusów w przypadku, gdy wykorzystywane jest pobieranie wielowątkowe (w przypadku wielu managerów pobierania).
Wszystkie protokoły: Filtr zawartości nie skanuje plików większych niż 2 megabajty.
Ustawienia filtrowania znajdziesz na następujących panelach:
• Ustawienia (Settings)
• Opcje skanowania (Scanning options)
• Statystyki (Statistics)

Ustawienia (Settings)

Ogólne ustawienia modułu można zmodyfikować na panelu prostym lub, klikając na przycisk |Zaawansowane| (Advanced), można przejść do panelu zaawansowanego, który umożliwia dostęp do większej liczby ustawień.

Ustawienia proste (Simple settings)

Filtr zawartości można włączyć lub wyłączyć dla każdego z protokołów. Ochronę można uaktywnić klikając na opcję Włączony na panelu danego protokołu.
• Filtrowanie wiadomości pocztowych (Mail filtering)
Zapewnia ochronę antywirusową w ruchu e-mailowym przy użyciu protokołów POP3, IMAP oraz SMTP. Protokoły, które mają być chronione można wybrać na nowym panelu klikając na przycisk |Ustawienia| (Settings). Panel można zamknąć klikając na przycisk |Powrót| (Back).
• Filtrowanie ruchu od/do przeglądarki internetowej (HTTP) (Browser (HTTP) filtering)
Analizuje i chroni przepływ danych przy użyciu protokołu HTTP.
• Filtrowanie transferu plików (FTP) (File transfer (FTP) filtering)
Zapewnia ochronę antywirusową przepływowi danych przy użyciu protokołu FTP. W chwili obecnej analizowany jest przepływ danych do klienta (download).

Ustawienia zaawansowane (Advanced settings)

Protokoły komunikacyjne używają do komunikacji z urządzeniami zewnętrznymi różnych portów. Na tym panelu można modyfikować ustawienia ochrony antywirusowej dla takiego przepływu danych. Tutaj można ustawić protokoły, które mają być skanowane oraz bezpieczne adresy sieciowe, (z których przepływ danych nie będzie skanowany)..

Typ protokołu, który ma być skanowany możesz wybrać z listy rozwijanej Protokół (Protocol). Po wybraniu protokołu podaj numer portu w okienku Chronione porty (Protected ports) (numery portów, poprzez które chcesz skanować przepływ danych przy użyciu wybranych protokołów). Możesz to zrobić wpisując żądaną wartość w polu tekstowym, a następnie dodając ją poprzez wciśnięcie przycisku |Dodaj| (Add). Możesz usunąć wartości z listy zaznaczając żądaną wartość i klikając na przycisk |Usuń| (Delete). Jeśli chcesz by wybrany protokół był chroniony na wszystkich istniejących portach, uruchom funkcję Skanuj wszystkie porty (Scan all ports) (może to spowodować znaczne obciążenie sieci). Jeśli wybierzesz wartość Wszystkie protokoły (All protocols) z listy rozwijanej Protokół (Protocol), wszystkie protokoły będą skanowane na portach ustawionych dla tej wartości.

W oknie Bezpieczne adresy IP (Trusted IP addresses), możesz dodać adresy IP dla protokołów wybranych z listy rozwijanej Protokół (Protocol) - przepływ danych z tych adresów nie będzie skanowany. Po wpisaniu konkretnego adresu IP w polu tekstowym możesz go dodać do listy bezpiecznych adresów przy pomocy przycisku |Dodaj| (Add), adres możesz później usunąć zaznaczając go na liście i klikając na przycisk |Usuń| (Delete). Tak jak opisano powyżej, system potraktuje jako bezpieczne wszystkie adresy IP, które zostały wpisane dla wartości Wszystkie protokoły (All protocols).

W przypadku ustawień domyślnych, system skanuje przepływ danych przy użyciu różnych protokołów na najczęściej używanych portach.

Opcje skanowania (Scanning options)

Na tym panelu można zmodyfikować ustawienia skanowania wirusów.
Metodę skanowania można ustawić na jeden z następujących poziomów:
• Szybkie/Rozległe/Pełne (Fast/Extensive/Full )
Analizę heurystyczną można ustawić na jeden z następujących poziomów:
• Wyłączona/Średnia/Wysoka (Off/Medium/High)
Opis ustawień Po wykryciu wirusa znajdziesz w części zatytułowanej Skaner!
W przypadku wykrycia wirusa możliwe są następujące działania:
• Zniszcz/Zastosuj kwarantannę/Pomiń/Usuń (Kill/Move to quarantine/Skip/Delete)
W przypadku wykrycia wirusa w wyniku analizy heurystycznej możliwe są następujące drugorzędne działania:
• Zastosuj kwarantannę/Pomiń/Usuń (Move to quarantine/Skip/Delete)
Po włączeniu opcji Komunikacja interaktywna (Interactive communication) oprogramowanie, ilekroć wykryje zainfekowany plik, zapyta użytkownika, jakie działanie należy wykonać. Jeśli opcja ta jest wyłączona, program automatycznie wykona na zainfekowanym pliku działanie zaznaczone jako domyślne.
Jeśli włączona jest opcja Skanuj archiwa (Scan compressed files), program będzie skanował wszystkie archiwa w poszukiwaniu wirusów.
Uwaga!
W przypadku skanowania ruchu w protokołach HTTP i FTP, jeśli wybierzesz opcję Usuń lub Zastosuj kwarantannę, poza wykonaniem zleconej operacji (usunięcia lub zastosowania kwarantanny) dany plik (jego nazwa i rozszerzenie) nie zostanie usunięty z oryginalnego katalogu, do którego został on pobrany, ale jego zawartość zostanie zastąpiona wiadomością tekstową informującą o podjętej przez ciebie akcji. Jeśli spróbujesz uruchomić pliki wykonywalne stworzone tą metodą (z wstawioną wiadomością tekstową) wyświetli się komunikat błędu, ponieważ system nie będzie w stanie uruchomić niepoprawnego pliku wykonywalnego (wypełnionego tekstem).

Statystyki (Statistics)

Statystyki zawierają szczegółowe wyniki analizy przepływu danych przy użyciu żądanych protokołów oraz informacje o incydentach (wykrytych wirusach).

Statystyki można odświeżyć klikając na przycisk |Odśwież| (Refresh).


Aktualizacje oprogramowania

Dla zachowania skuteczności ochrony bardzo ważna jest aktualizacja oprogramowania i bazy danych wirusów.
Aktualizacja oprogramowania opiera się na zadaniach: proces aktualizacji można uruchomić kilkoma kliknięciami, można go także zaplanować na konkretny dzień, lub w odpowiedzi na konkretne zdarzenie, zostanie on wtedy przeprowadzony zgodnie z wcześniej ustalonymi ustawieniami. Zadania aktualizacji oprogramowania można dodawać lub modyfikować w module Aktualizator (Updater), który zapewnia interfejs do tworzenia krok-po-kroku zadań umożliwiających ustawianie opcji i parametrów potrzebnych do przeprowadzenia aktualizacji.
Produkt używa przyrostowy mechanizm uaktualniając na bieżąco bazę danych sygnatur. Jest to korzystne dlatego, że nie musimy ściągać za każdym razem całej bazy sygnatur (zwykle zajmuje kilka MB) tylko zazwyczaj mały dodany pakiet zawierający sygnatury ostatnio wypuszczonych wirusów. Dzieki temu mechanizmowi czas potrzebny na aktualizację jest minimalnie skrócony, co pozwala publikować po kilka aktualizacji baz sygnatur dziennie. To wydatnie podnosi ochronę. Uzytkownik może otrzymać ochronę na nowe MALWERS'Y bez spędzania długiego czasu i generowania obciążania sieci na uaktualnianie. Ochrona jest dostępna niemalże natychmiastowo po opracowaniu w naszych labolatoriach sygnatur nowo odkrytego wirusa.

Żądane źródło aktualizacji można aktywować (w celu późniejszego przeprowadzania z niego aktualizacji) zaznaczając okienko wyboru znajdujące się przed jego nazwą w menu Zadania (Tasks) w ustawieniach Dozwolone źródła aktualizacji (Allowed update sources). Po przeprowadzeniu powyższej operacji można będzie wybierać źródło w celu dodania nowego zadania lub modyfikacji już istniejącego. Informacje o źródle wyświetlają się obok jego nazwy, można je zmodyfikować klikając na przycisk |Ustawienia źródła ...| (Source settings ...).W tym oknie można zmodyfikować ustawienia każdego źródła. Ustawienia elementu wybranego z listy rozwijanej można zmodyfikować w dolnej części panelu. Zapamiętaj, że każde zadanie będzie próbowało aktualizować się jedynie poprzez przyporządkowane mu źródło aktualizacji.
Uwaga!
Jeżeli źródło, które wybrano do przeprowadzania danego zadania, jest nieaktywne, zadania nie można przeprowadzić bez uprzedniej reaktywacji źródła.
Oto możliwe źródła aktualizacji oraz ich ustawienia:
• HTTP
Aktualizacja za pośrednictwem protokołu HTTP. Konieczne jest podanie nazwy serwera HTTP, używanego portu (domyślnie 80), oraz ścieżki, na której znajduje się plik opisu. Ustawienie domyślne to:
update.virusbuster.hu:80/pub2006
Jeżeli serwer wymaga autentykacji Proxy (Proxy authentication), wpisz nazwę użytkownika Proxy i hasło w dostępne pola (w przypadku korzystania z ustawienia domyślnego nie ma takiej potrzeby).
• FTP
Aktualizacja za pośrednictwem protokołu FTP. W celu zalogowania się konieczne jest podanie nazwy serwera FTP, portu, z którego korzysta serwer (domyślnie 21), oraz ścieżki, na której znajduje się plik opisu, a także nazwy użytkownika i hasła. Jeśli korzystasz z opcji użytkownika ‘Anonymous’, wpisz swój adres mailowy w polu “hasło”. Ustawienie domyślne to: anonymous@update.virusbuster.hu:21/pub2006
• Ścieżka NetWare (NetWare path)
Aktualizację można przeprowadzić z serwera Novell NetWare, należy wpisać żądaną ścieżkę w polu w formacie UNC (\\servername\sharename).
• Ścieżka (Path)
Aktualizację można przeprowadzić z napędu lokalnego lub sieciowego. Ścieżkę można określić klikając na przycisk |...|.
• Napęd CD (CD drive)
Jeśli aktualizacja jest przeprowadzana z CD, wybierz literę napędu z listy rozwijanej.
Uwaga!
Aktualizację ze ścieżki lokalnej lub sieciowej można przeprowadzić wyłącznie wtedy, gdy użytkownik jest zalogowany do domeny!
Aktualizację ze ścieżki sieci Novell NetWare można przeprowadzić wyłącznie wtedy, gdy użytkownik jest zalogowany do serwera!

W dolnej części panelu można dodawać nowe zadania, a także oglądać, modyfikować, uruchamiać bądź zatrzymywać zadania już istniejące. W pierwszej kolumnie listy zadań wyświetlają się nazwy zadań, w następnych kolumnach data ostatniego uruchomienia, data następnego uruchomienia, lub zdarzenie uruchamiające zadanie. Ostatnia kolumna informuje, czy zadanie jest zatrzymane.
Klikając na odpowiedni przycisk w dolnej części panelu można wykonać następujące operacje:
• |Nowe zadanie| (New task)
Opcja ta pozwala na stworzenie nowego zadania i określenie jego ustawień.
• |Modyfikuj| (Modify)
Opcja ta pozwala na modyfikację ustawień wybranego zadania.
• |Usuń| (Delete)
Opcja ta usuwa wybrane zadanie.
• |Uruchom| (Start)
Opcja ta pozwala na uruchomienie wybranego zadania.
• |Wstrzymaj| (Suspend)
Opcja ta wstrzymuje wybrane zadanie: zadanie nie może być uruchomione i nie będzie uruchomione bez ponownej autoryzacji.

Tworzenie nowego zadania

Ustawienia nowego zadania można dodawać krok po kroku, właściwości zadania można modyfikować na poszczególnych etapach.

Produkty (Products)

Pierwszym krokiem jest wybór produktu/produktów do zadania aktualizacji. Zadanie sprawdzi czy wybrany produkt/wybrane produkty są aktualne, jeśli istnieją nowe wersje produktu/produktów, pobierze je i przeprowadzi aktualizację systemu. Na liście znajdują się zainstalowane produkty oraz plik z bazą danych wirusów, dany element można wybrać zaznaczając okienko znajdujące się przed nim. Aby móc przejść do następnego kroku definiowania zadania należy wybrać przynajmniej jeden element z listy.

Harmonogram (Scheduling)

Na tym panelu można ustalić harmonogram uruchomiania procesu aktualizacji: w tym celu należy podać żądaną datę, lub zdarzenie, które uruchomi aktualizację.

Zadanie aktualizacji zostanie uruchomione i wykonane przy wykorzystaniu przywilejów użytkownika zawartych w profilu użytkownika ustawionym w polu Użytkownik:. Hasło potrzebne do zalogowania użytkownika można podać po kliknięciu na przycisk |Hasło ...| (Password ...).
Ustawienia proste (Simple settings)
Przy planowaniu czasu rozpoczęcia zadania można wybrać następujące terminy:
• Dzień (dni)/tydzień (tygodnie)
Można tu podać konkretną liczbę, oprogramowanie będzie rozpoczynało aktualizację, co x (określoną liczbę) dni lub tygodni. W wybranym dniu zadanie zostanie uruchomione, gdy użytkownik zaloguje się do systemu, i będzie dostępne połączenie z siecią. Jeśli uruchomienie zadania się nie powiedzie oprogramowanie będzie podejmować próby uruchomienia po każdym zalogowaniu się użytkownika, do momentu, gdy proces zakończy się pomyślnie.
• Uruchamianie manualne
Użytkownik musi uruchomić zadanie manualnie. Zadanie może zostać uruchomione, gdy zostanie wybrane.

Ustawienia zaawansowane (Advanced settings)
Na panelu harmonogramu szczegółowego dostępne są następujące ustawienia:
• dzień (dni)/tydzień (tygodnie)/godzina (godziny)
• manualne
• w/g harmonogramu
Można ustawić dokładny czas rozpoczęcia zadania (godziny, minuty), następnie można określić dni, w które zadanie ma być uruchamiane.
• co 15 minut / co pół godziny
Zadanie będzie uruchamiane o ustalonej porze w wybrany dzień (dni).

Źródła aktualizacji (Update sources)

Ustawienia proste (Simple settings)
Źródło aktualizacji możesz wybrać z listy rozwijanej, oprogramowanie będzie o określonym czasie sprawdzać czy dostępne są nowe aktualizacje. Dostępne są wyłącznie aktywne źródła aktualizacji, które można ustawić na głównym panelu Aktualizatora w punkcie Dozwolone źródła aktualizacji (Allowed update sources). Ustawienia źródeł aktualizacji można zmodyfikować globalnie klikając na przycisk |Ustawienia ...| (Settings ...).

Jeśli zaznaczysz opcję Okno postępu będzie pokazane (Progress dialog will be displayed), będziesz mógł śledzić proces aktualizacji, w przeciwnym razie proces będzie przebiegał “w tle”, bez wyświetlania okien.

Po włączeniu opcji Tryb interaktywny (Interactive mode), jeśli zaznaczone jest ustawienie Okno postępu będzie pokazane postępu (Progress dialog will be displayed), użytkownik będzie w stanie śledzić cały proces aktualizacji krok po kroku oraz tymczasowo zmieniać ustawienia zadania.

Opcja Zabroniony restart komputera (Computer restart disable) kontroluje ponowne uruchamianie systemu. Jeśli zaznaczysz tą opcję, komputer nie będzie ponownie uruchomiany po zakończeniu procesu aktualizacji.
Uwaga!
Nie wyłączaj opcji ponownego uruchamiania komputera, jeśli nie ma po temu uzasadnionych powodów: w trakcie procesu aktualizacji mogą nastąpić zmiany, które będą wymagały aktywacji funkcji ponownego uruchomienia komputera. Jeśli funkcja ta będzie wyłączona, istnieje możliwość, że ochrona rezydentna komputera nie będzie aktywowana, wskutek czego twój komputer będzie pozbawiony ochrony!
Ustawienia zaawansowane (Advanced settings)
Wszystkie powyższe opcje znajdują się na interfejsie zaawansowanym. Tryb pracy Aktualizatora w sieci można określić przy pomocy opcji Dostęp sieciowy (Network access).

Jeśli wybierzesz opcję Stałe połączenie z siecią (Continuous network connection), uruchomione zadanie nie będzie podejmowało prób ustanowienia połączenia sieciowego, jeżeli zaś dostęp do sieci nie będzie możliwy, pojawi się zawiadomienie o błędzie. Jeśli wybierzesz opcję Ustanów połączenie z siecią w celu aktualizacji (Establish network connection for updates), (gdy stałe połączenie z siecią nie jest dostępne, np. w przypadku połączenia telefonicznego) zadanie ustanowi połączenie z siecią i zakończy je, gdy zadanie zostanie wykonane, (jeśli połączenie zostało ustanowione przez program). Druga opcja aktywuje Ustawienia połączeń sieciowych (Network connection settings), w których możesz wybrać żądany profil sieci z listy rozwijanej, a także podać odpowiednie hasło.

Nazwa zadania (Task’s name)

Aby nadać nazwę zadaniu wpisz żądaną nazwę w pole Nazwa zadania. W przyszłości będziesz mógł używać tej nazwy w odniesieniu do konkretnego zadania: znajdzie się ona w oknie zawierającym listę Zadania na panelu Zadania. Dodanie dwóch zadań o tej samej nazwie nie jest możliwe, w nazwie zadania nie można używać znaku \ (lewego ukośnika).

Podsumowanie (Summary)

Na tym panelu można dokonać przeglądu ustawień określonych w trakcie etapów opisanych powyżej. Jeśli ustawienia zadania są prawidłowe, można je zachować klikając na przycisk |Zakończ| (Finish). Możesz cofnąć się do poprzedniego panelu ustawień klikając na przycisk |Powrót| (Back). Możesz także “przeskoczyć” z powrotem do głównego panelu Aktualizatora klikając na przycisk |Anuluj| (Cancel) - wszystkie ustawienia zostaną utracone (nowe zadanie nie zostanie stworzone, modyfikacje nie zostaną zachowane).

Modyfikacja zadania aktualizacji

Przy modyfikacji zadania przechodzi się te same etapy, co podczas dodawania nowego zadania.
• Podsumowanie (Summary)
Tu możesz sprawdzić ustawienia zadania.
• Produkty (Products)
Tu możesz zmodyfikować listę produktów, które powinny być aktualizowane (Panel Produkty).
• Harmonogram (Scheduling)
Tu możesz zmodyfikować harmonogram zadania (Panel Harmonogram).
• Źródło aktualizacji (Update source)
Tu możesz wybrać nowe źródło aktualizacji dla zadania (Panel Źródło aktualizacji).
• Nazwa zadania (Task name)
Nie możesz zmodyfikować nazwy zadania. Ustawienie to identyfikuje zadanie, które jest modyfikowane.
• Podsumowanie (Summary)
Podsumowanie zmodyfikowanych ustawień (Panel Podsumowanie).

Uruchamianie zadania aktualizacji

Zadanie aktualizacji – w zależności od swoich ustawień – może być uruchamiane w konkretnym (zaplanowanym) momencie, może być uruchamiane przez jakieś wydarzenie (start systemu), lub może je uruchomić manualnie użytkownik.

Poszczególne etapy zadania aktualizacji można śledzić, jeśli jest to zadanie interaktywne, co można określić w trakcie dodawania zadania lub modyfikacji jego ustawień na panelu Źródła aktualizacji (Update sources).
Działanie zadania można zautomatyzować na każdym z etapów – w tym celu należy wybrać opcję Operacja automatyczna (Automatic operation) na dole panelu. W takim przypadku program będzie automatycznie wykonywał poszczególne etapy aktualizacji, zaś użytkownik będzie miał możliwość prześledzenia podsumowania procesu aktualizacji na panelu Podsumowanie (Summary).

Po rozpoczęciu procesu aktualizacji program zbiera informacje o wersjach produktów i komponentów, a następnie porównuje te informacje z informacjami przechowywanymi w wybranym źródle aktualizacji. Jeśli potrzebna jest jakakolwiek aktualizacja (w źródle aktualizacji dostępne są nowe wersje) program pobiera je do komputera i przeprowadza aktualizację programów i modułów.

W trakcie działania interaktywnego możliwe jest śledzenie procesu aktualizacji, a wyniki pojawiają się na panelu Podsumowanie (Summary).

Przygotuj (Prepare)

Tu wyświetlają się główne ustawienia zadania aktualizacji.
Uwaga!
Możliwa jest modyfikacja ustawień przed uruchomieniem zadania, ustawienia te będą obowiązywały tymczasowo dla rozpoczętego zadania!

Aktualizator będzie próbował przeprowadzić aktualizację produktów, które są wyświetlone w oknie Produkty (Products). Lista w tym oknie posiada dwie kolumny: pierwsza z nich pokazuje nazwy produktów, druga – informacje o ich rozmiarze (w megabajtach). Przed nazwami produktów wyświetlanymi w pierwszej kolumnie znajdują się okienka wyboru, przy pomocy, których możesz zablokować produkty, które nie mają być aktualizowane.

W dolnej części panelu wyświetlają się najważniejsze ustawienia programu, źródło aktualizacji można zmodyfikować, klikając na przycisk |Ustawienia ...| (Settings ...). Ustawienie każdego ze źródeł można zmodyfikować w oknie, które się pojawi.

Jeśli istnieje taka potrzeba, po zakończeniu zadania program ponownie uruchomi komputer. Jeśli opcja Restart komputera (Restart komputer) jest włączona, komputer zostanie ponownie uruchomiony we wszystkich przypadkach.

Możesz przejść do następnego panelu klikając na przycisk |Dalej| (Next), aktualizację możesz zakończyć, klikając na przycisk |Anuluj| (Cancel).

Kwerenda (Data query)

W tym kroku Aktualizator pobiera ze źródła aktualizacji informacje o elementach oprogramowania przeznaczonych do aktualizacji. Elementy te wyświetlają się w górnej części okna, dolna część okna zawiera informacje o statusie zbierania danych.

Pasek statusu Bieżący proces (Current process) informuje o statusie procesu zbierania danych. Możesz zobaczyć tu prędkość pobierania danych, źródło aktualizacji, oraz katalog, do którego pobierane są tymczasowo pliki.

Jeśli wystąpi problem, możesz obejrzeć szczegółowe informacje o przyczynie problemu klikając na przycisk |Dalej| (Next) i przechodząc do panelu Podsumowanie (Summary). Jeżeli proces aktualizacji przebiegał bez problemów, możesz przejść do następnego panelu klikając na przycisk |Dalej| (Next), lub cofnąć się klikając na przycisk |Powrót| (Back), możesz również zakończyć proces aktualizacji klikając na przycisk |Anuluj| (Cancel).

Wybór produktu (Product selection)

Listę produktów, które mają zostać poddane aktualizacji możesz zmodyfikować na tym panelu, w jego górnej części, w oknie zatytułowanym Produkty (Products).

Numer wersji produktu, jego rozmiar, oraz szacunkowy czas pobierania jest wyświetlany obok nazwy produktu.
Na dole, w części zatytułowanej Pobieranie wyświetlane są następujące informacje:
• Rozmiar elementów pobieranych (Download size)
Rozmiar wybranych komponentów programu.
• Szacunkowy czas pobierania (Estimated download time)
Szacunkowy czas potrzebny na pobranie wszystkich komponentów.
• Prędkość pobierania (Download speed)
Szacunkowa prędkość pobierania plików.
Poniżej można aktywować opcję działania automatycznego.

Po zakończeniu pobierania, możesz przejść do następnego panelu klikając na przycisk

Pobieranie (Download)

Pobrane produkty wyświetlają się na górze panelu, w oknie zatytułowanym Produkty (Products).

Zielona strzałka na ikonie CD przed produktem oznacza, że dany produkt jest aktualnie pobierany. Obecny status tego produktu i informacje o nim wyświetlają się na dole, w części zatytułowanej Pobieranie. Jeżeli proces pobierania zakończył się powodzeniem, ikona jest zaznaczona zielonym “ptaszkiem”. Czerwony wykrzyknik oznacza, że w trakcie pobierania pojawił się problem. W przypadku wystąpienia problemu możesz kliknąć na przycisk |Dalej| (Next) i zapoznać się ze szczegółowymi informacjami o przyczynie problemu panelu Podsumowanie (Summary).

Jeżeli proces pobierania przebiegał bez problemów możesz przejść do następnego panelu klikając na przycisk |Dalej| (Next).

Podsumowanie procesu pobierania (Download summary)

W przypadku, gdy proces pobierania zakończył się powodzeniem, pobrane komponenty programu, ich rozmiary oraz numery wersji można odczytać na panelu podsumowania.

Na dole okna pojawia się informacja, że aktualizacja wybranych programów i komponentów zostanie przeprowadzona w następnym kroku.

Pod źródłem aktualizacji wyświetla się status ponownego uruchomienia komputera, włączając tę opcję możesz przejść na działanie automatyczne.

Instalacja (Installation)

W tym kroku zaznaczone i pobrane elementy zostaną zainstalowane.

Tak jak opisano to powyżej, ikona CD znajdująca się przed produktami informuje o statusie (procesu) pobierania, natomiast pasek statusu na dole panelu informuje o aktualnym stanie aktualizacji.

W trakcie przeprowadzania instalacji i aktualizacji nowych wersji program wstrzymuje działanie swoich aplikacji. Może to potrwać kilka minut!

Możesz przejść dalej wyłącznie, jeśli aktualizacja została zakończona lub jeśli wystąpił problem.

Podsumowanie (Summary)

Ostatnim krokiem procesu aktualizacji jest podsumowanie, które dostarcza informacji o aktualizacjach ukończonych pomyślnie lub o problemach, które wystąpiły. Cały proces aktualizacji można zakończyć klikając na przycisk |Zakończ| (Finish).
Aktualizacja pomyślna
W przypadku aktualizacji zakończonej pomyślnie, w górnej części okna wyświetlą się nowe numery wersji zaktualizowanych aplikacji oraz data aktualizacji. W dolnej części okna wyświetlają się statystyki: czas potrzebny na wykonanie zadania i rozmiar przetransferowanych danych.

Jeśli ustawiono funkcję automatycznego ponownego uruchomienia komputera, panel będzie zawierał pasek statusu, który będzie odliczał czas jednej minuty, po którym komputer zostanie ponownie uruchomiony. Istnieje możliwość przerwania procesu ponownego uruchamiania komputera, można też rozpocząć ponowne uruchomienie natychmiast.
Problemy w aktualizacji
Jeżeli wystąpił problem, w dolnej części panelu możesz uzyskać szczegółowe informacje o problemie oraz o możliwych sposobach jego rozwiązania.
Wybierając opcję Wyślij do VirusBuster’a (Mail to VirusBuster) i klikając na przycisk |Zakończ| (Finish), możesz przesłać zawiadomienie o problemie do VirusBuster’a, nasz personel przeanalizuje problem i zawiadomi cię o możliwych sposobach jego rozwiązania.
Jeśli opcja ta jest niedostępna (nie możesz jej wybrać), dokonaj ustawień komponentu Mailer. Prawidłowe ustawienia Mailer’a są niezbędne przy wysyłaniu wiadomości.
Jeśli chcesz wysłać wiadomość, jej zawartość i ustawienia możesz obejrzeć po kliknięciu na przycisk |Zobacz raport o problemie...| (View problem report...). Panel ten zawiera adres nadawcy i odbiorcy, plik archiwum report.zip który zostanie dołączony do wiadomości, można go obejrzeć po kliknięciu na przycisk |Przeglądaj ...| (Browse ...). To archiwum zawiera pliki niezbędne do odnalezienia oraz przeanalizowania problemu.

Szybka aktualizacja bazy

Klikając na przycisk Aktualizuj |Update| na stronie głównej interfejsu graficznego możesz uruchomić tzw. “szybką” aktualizację bazy (jeśli ta funkcja jest dostępna). W takim przypadku program pobiera źródło z listy aktywnych źródeł i z niego próbuje pobrać i aktualizować bazę. Różne poziomy są dostępne, ale do pobierania jest wykorzystane zawsze aktywne oraz najbliżej przodu listy.
Poziomy źródeł aktualizacji (od najwyższego):
• Ścieżka (Path)
• Ścieżka sieciowa (NetWare path)
• CD
• HTTP
• FTP


Skaner

Komponent ten wykonuje wszystkie zadania skanowania wirusów i umożliwia manualne skanowanie antywirusowe. Działanie komponentu jest oparte o zadania - pozwala użytkownikowi przeprowadzać skanowanie według jednego z ustawionych zadań, w którym zdefiniowana została wcześniej metoda skanowania i inne opcje. Sprawia to, że możliwe jest natychmiastowe skanowanie, bez konieczności określania indywidualnych ustawień skanowania. Ustawienia zadań skanowania można zmodyfikować w menu Zadania (Tasks), skanowanie manualne można uruchomić przy użyciu funkcji Uruchom skanowanie (Start scan).

Zadania

Na panelu Zadania (Tasks) można obejrzeć domyślne oraz zdefiniowane przez użytkownika zadania skanowania.
Dostępne zadania wyświetlane są w oknie Zadania. Okno to zawiera tylko trzy zadania domyślne, są to:
• Skanuj tylko napędy wymienne tylko do odczytu (Scan only read-only removable drives)
• Skanuj tylko zapisywalne napędy wymienne (Scan writable removable drives)
• Skanuj lokalne dyski twarde (Scan local hard drives)
Po prawej stronie panelu w oknie Zadania (Tasks), wyświetlane są główne ustawienia wybranego zadania. Informacji tych nie można zmodyfikować w tym miejscu.
Przed nazwami zadań znajdują się ikony oznaczające rodzaj zadania. Używane są następujące ikony:
Zadanie jest uruchamiane przez zdarzenie (uruchamianie systemu).
Zadanie jest uruchamiane manualnie przez użytkownika.
Zadanie jest uruchamiane w/g harmonogramu - określonym czasie lub okresowo.
Klikając na niżej wymienione przyciski można uruchomić następujące funkcje:
• |Dodaj zadanie| (Add task)
Tworzy indywidualne zadanie skanowania o określonych ustawieniach skanowania.
• |Modyfikuj| (Modify)
Modyfikuje ustawienia wybranego zadania.
• |Usuń| (Delete)
Usuwa wybrane zadanie.
• |Uruchom| (Start)
Uruchamia wybrane zadanie.
Opis okna, w którym wyświetla się proces skanowania, znajdziesz w części zatytułowanej Okno skanowania antywirusowego.

Utwórz nowe zadanie

Po kliknięciu na przycisk |Dodaj zadanie| (Add task), pojawi się okno kreatora, w którym można, z pomocą szczegółowych opisów, krok po kroku określić ustawienia nowego zadania. Możesz przejść do przodu klikając na przycisk |Dalej| (Next). Proces dodawania nowego zadania można przerwać klikając na przycisk |Anuluj| (Cancel). Ustawienia można z łatwością określić na panelu ustawień prostych, można także dopasować szczegóły po kliknięciu na przycisk |Zaawansowane| (Advanced).
Obszary skanowania – wybór napędów, które mają być skanowane
Ustawienia proste
Poprzez wybranie żądanych typów napędów możesz określić, które napędy mają być skanowane. Przycisk Dalej (Next) stanie się aktywny tylko, jeśli wybrano przynajmniej jeden rodzaj (napędu). Dostępne są niżej wymienione ustawienia:
• Dyski wymienne (Removable dinks)
Dyski wymienne można z łatwością usunąć z komputera. Na przykład: dyskietka, CD/DVD ROM.
• Lokalne dyski twarde (Local hard drives)
Lokalne dyski twarde to dyski na stałe umieszczone w komputerze.
• Dyski sieciowe (Network drives)
Dyski sieciowe to dyski, z których można korzystać poprzez sieć. Fizycznie nie stanowią one części twojego lokalnego komputera.
Ustawienia zaawansowane

Napędy lub konkretne katalogi, które mają być skanowane, można ustawić na panelu Zaawansowanym (Advanced). Napędy i katalogi dostępne w (danym) komputerze są wyświetlane w oknie o nazwie Obszary skanowania (Scan areas). Znak plus informuje czy katalog posiada podkatalogi. Jeśli katalog zostanie otwarty, a jego podkatalogi wyświetlone, znak plus zostanie zastąpiony przez minus. Katalog można otworzyć klikając jednokrotnie na jego nazwę lub na znak plus. Jeśli zaznaczono okienko wyboru znajdujące się przed nazwą katalogu, pliki katalogu zostaną poddane skanowaniu. Status katalogu (otwarty – zamknięty) jest niezmiernie ważny w trakcie zaznaczania okienek wyboru, jeśli katalog jest otwarty, jego podkatalogi nie zostaną poddane skanowaniu. Jeśli katalog jest zamknięty, zaznaczenie okna wyboru zostanie zastosowane rekursywnie do wszystkich podkatalogów. Katalogi, które zostały zaznaczone rekursywnie są zaznaczone gwiazdką (*).

Jeśli twój komputer stanowi część sieci, możesz dodać dzielone napędy sieciowe do skanowania klikając na przycisk |Sieć...| (Network...). W oknie, które się pojawi musisz wybrać żądaną ścieżkę, a następnie kliknąć na przycisk |Dodaj| (Add). Wybrana ścieżka zostanie dodana do już istniejących.
Ustawienia – określanie metody skanowania
Ustawienia proste

Po wybraniu opcji skanowania W rozszerzeniach domyślnych (In default extensions) skaner przeprowadza skanowanie wyłącznie tych rodzajów plików, które są ustawione domyślnie. Są one opisane w części zatytułowanej Ustawienia rozszerzeń.

Po wybraniu opcji We wszystkich plikach (In all files) możliwe jest skanowanie wszystkich plików. W takim przypadku skanowane będą wszystkie pliki, niezależnie od ich rozszerzeń.
Na następnym panelu, wybierając spośród predefiniowanych metod skanowania, można określić metodę skanowania i usuwania wirusów, oraz inne ustawienia skanera. Metody te to zestaw ustawień, które można obejrzeć korzystając z panelu Zaawansowanego (Advanced).
• Szybkie skanowanie (Quick scan)
Wykorzystuje Szybką metodę skanowania, brak heurystyki, wszystkie wirusy zostaną Pominięte. Jest to proces automatyczny, nie wymaga udziału użytkownika. Predefiniowane operacje zostaną przeprowadzone na zainfekowanych plikach.
• Skanowanie i usuwanie interaktywne (Interactive scanning and removal)
Wykorzystuje metodę Rozległego Extensive skanowania, Średnią heurystyka, wirusy usuwalne zostaną Zniszczone, wirusy nieusuwalne zostaną Poddane kwarantannie. Udział użytkownika jest konieczny w przypadku wykrycia wirusa: predefiniowane operacje muszą zostać potwierdzone.
• Odkażanie automatyczne (Automatic disinfection)
Wykorzystuje metodę Pełnego skanowania, Średnią heurystyka, wirusy usuwalne zostaną Zniszczone, wirusy nieusuwalne zostaną Poddane kwarantannie. Jest to proces automatyczny, nie wymaga udziału użytkownika. Na zainfekowanych plikach zostaną przeprowadzone predefiniowane operacje.
Ustawienia zaawansowane
Po włączeniu opcji Skanuj wszystkie pliki (Scan all files), skanowaniu poddawane będą wszystkie rodzaje plików (o różnych rozszerzeniach). Po włączeniu opcji Skanuj pliki o określonych rozszerzeniach (Scan files with specified extension(s)), skanowaniu poddawane będą wyłącznie pliki o rozszerzeniach określonych przez użytkownika. Wartości domyślne można zmodyfikować klikając na przycisk |Rozszerzenia ...| (Extensions ...).
• Ustawienia rozszerzeń (Extension settings)
Poniższe rodzaje plików będą skanowane domyślnie:
- Pliki silnika bazy danych (Jet engine)
- Pliki baz danych
- Archiwa
- Dokumenty
- Pliki Power Point’a
- Pliki programów
- Pliki zawierające skrypty
Dla poszczególnych plików można ustawić opcję skanowania bądź nieskanowania. W tym celu należy odpowiednio włączyć opcję Pliki do skanowania (Files to be scanned) lub Pliki nie do skanowania (Files not to be scanned), żądane rodzaje plików należy określić w podanych polach (np. *.rxx). Można używać znaków specjalnych (np. *.qwe, *.?ab).
Jeśli włączona jest opcja Skanuj archiwa (Scan compressions) program będzie przeprowadzał skanowanie wszystkich archiwów. Jeśli włączona jest opcja Skanuj pamięć (Scan menory), program rozpocznie skanowanie od sprawdzenia zawartości pamięci, potem przejdzie do skanowania podanych obszarów skanowania.
Metodę skanowania można ustawić na jeden z następujących poziomów:
• Szybkie/Szczegółowe/Pełne (Fast/Extensive/Full)
Analizę heurystyczną można ustawić na jeden z następujących poziomów:
• Wyłączona/Normalna/Silna (Disabled/Normal/Strong)
Na panelu ustawień W przypadku znalezienia wirusa (Virus found settings) możesz określić operacje, które mają być przeprowadzane (tryb automatyczny), lub sugerowane (tryb interaktywny) w przypadku wykrycia wirusa. W opcji Znaleziono wirus (Virus found) można ustawić wybraną operację główną. Jeżeli operacji tej nie da się przeprowadzić (np. wirusa nie można usunąć), zostanie przeprowadzona lub zasugerowana operacja drugorzędna, która została ustawiona w opcji Operacja w przypadku niepomyślnego odkażenia (In case of unsuccessful disinfection). W przypadku wykrycia wirusa, na pliku można przeprowadzić wszystkie operacje z wyjątkiem Zniszcz (Kill), dlatego nie ma potrzeby ustawiania operacji drugorzędnej, jeśli wartość ustawiona dla operacji głównej jest inna niż Zniszcz (Kill). Możesz tu też ustawić operację do stosowania w przypadku wykrycia wirusa w wyniku analizy heurystycznej.
Operacje dostępne w przypadku wykrycia wirusa:
• Zniszcz/Pomiń/Przemianuj/Poddaj kwarantannie/Usuń (Kill/Skip/Rename/Move to quarantine/Delete)
Operacje drugorzędne dostępne w przypadku wykrycia w wyniku analizy heurystycznej:
• Pomiń/Przemianuj/Poddaj kwarantannie/Usuń (Skip/Rename/Move to quarantine/Delete)
Jeśli włączona jest opcja Komunikacja interaktywna (Interactive communication), oprogramowanie będzie domagało się interakcji użytkownika w każdym przypadku wystąpienia problemu, zdefiniowane operacje będą wyświetlane domyślnie. Jeśli opcja ta nie jest włączona zdefiniowane operacje zostaną automatycznie przeprowadzone na zainfekowanych plikach.
Panel harmonogramu – ustawianie czasu rozpoczęcia skanowania
Na tym panelu można z łatwością ustalić harmonogram wykonywania zadań skanowania – rozpoczęcia skanowania antywirusowego. Spośród różnych opcji możesz wybrać żądaną częstotliwość, konkretną datę, albo zdarzenie, które uruchomi skanowanie. Ustawienia na tym panelu są takie same jak opisano we fragmencie dotyczącym Aktualizatora w rozdziale zatytułowanym Harmonogram.
Nazwa zadania
Aby nadać nazwę zadaniu wpisz żądaną nazwę w pole tekstowe. Nazwa musi zostać podana, w przeciwnym wypadku dodanie zadania nie będzie możliwe.

Po naciśnięciu przycisku |Zakończ| (Finish), zostanie utworzone zadanie skanowania o konkretnych ustawieniach, a jego nazwa będzie wyświetlana w liście na panelu Zadania. Nie jest możliwe stworzenie dwóch zadań o tej samej nazwie, w nazwie zadania nie można stosować znaku \ (lewego ukośnika).

Modyfikacja zadania skanowania

Proces modyfikacji składa się z tych samych kroków i ustawień, które występują w procesie dodawania zadania.
• Modyfikacja obszaru skanowania (Modification of the scan area)
Możesz zmodyfikować docelowe obszary wybranego zadania skanowania (Panel Obszary skanowania).
• Ustawienia – wybór metody skanowania (Settings – specifying the scanning method)
Możesz zmienić ustawienia zadania skanowania (Panel Ustawienia – wybór metody skanowania).
• Harmonogram (Scheduling)
Istnieje możliwość modyfikacji harmonogramu (Panel Harmonogram).
• Nazwa zadania (Taks name)
Nie można zmodyfikować nazwy zadania, ponieważ jest to jedyne ustawienie służące do identyfikacji zadania. Możesz wrócić do panelu Zadania (Tasks) klikając na przycisk Zakończ |Zakończ| (Finish).

Uruchomienie skanowania

Jeżeli nie chcesz dodawać zadania skanowania, a jedynie przeprowadzić proste skanowanie, możesz określić żądane ustawienia w menu Uruchom skanowanie (Start scan). Ważne jest, by po wybraniu opcji z menu, a przed rozpoczęciem skanowania, określić obszary skanowania. Potem skanowanie można rozpocząć natychmiast klikając na przycisk |Skanuj| (Scan) znajdujący się w dolnej części okna (w takim przypadku parametry, które nie zostały określone przybiorą wartości domyślne). Przy konfigurowaniu skanowania manualnego dostępne są następujące ustawienia:
• Obszary skanowania (Scan areas)
W pierwszej kolejności należy określić napędy, które mają być poddane skanowaniu wirusów. Funkcjonowanie i ustawienia panelu są takie same jak opisano w części dotyczącej dodawania nowego zadania na panelu Obszary skanowania.
• Ustawienia (Settings)
Możesz ustawić rodzaje plików, które mają być poddawane skanowaniu, możesz także określić operacje, które mają zostać przeprowadzone w przypadku wykrycia wirusa. Panel ten jest taki sam jak opisano w części dotyczącej dodawania nowego zadania w sekcji Ustawienia.
• Uruchom skanowanie (Start scan)
Na tym panelu możesz obejrzeć główne parametry skanowania, a także rozpocząć skanowanie klikając na przycisk |Start|. Opis okna skanowania, które informuje o statusie skanowania znajdziesz w części zatytułowanej Okno skanowania.


Szybkie skanowanie

Skanowanie plików i folderów można rozpocząć nie tylko z interfejsu użytkownika i z Paska Zadań, ale również z każdego miejsca w systemie, przy pomocy lokalnych menu. Z komponentu Mój komputer (My Komputer) możesz przeprowadzić skanowanie całego napędu, z Explorer’a możesz przeprowadzić skanowanie całego katalogu lub tylko jednego pliku.
Po kliknięciu prawym klawiszem myszy na wybrany element (napęd, folder, plik) pojawi się menu lokalne, z którego, w celu przeprowadzenia skanowania wybranego elementu/elementów, należy wybrać opcję Skanowanie z VirusBuster’em (Scan with VirusBuster). Opis okna skanowania, które informuje o statusie skanowania, znajdziesz w części zatytułowanej Okno skanowania.


Ochrona MS Office (MS Office protection)

Komponent ten zapewnia ochronę aplikacjom MS Office oraz wykorzystywanym przez nie rodzajom plików. Ochrona klienta pocztowego MS Outlook jest realizowana przez osobny komponent.

Ustawienia ochrony można zmodyfikować na panelu Ustawienia (Settings). Właściwości Ochrony MS Office można ustawić na panelu ustawień prostych lub, po kliknięciu na przycisk |Zaawansowane| (Advanced), na panelu ustawień zaawansowanych, który umożliwia dostęp do większej liczby opcji.

Ustawienia proste

Ochrona staje się aktywna po zaznaczeniu opcji Aktywna (Active). Istnieją trzy alternatywne poziomy ochrony, które możesz z łatwością wybrać zaznaczając jeden z nich. Poziomy te to domyślne zestawy ustawień, każdy z nich możesz zmodyfikować po kliknięciu na przycisk |Zaawansowane| (Advanced).
Poziomy ochrony:
• Wysoki (High)
Korzysta z Pełnej (Full) opcji skanowania wirusów, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną poddane kwarantannie.
• Średni (Medium)
Korzysta ze Rozległej (Extensive) opcji skanowania wirusów, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną pominięte.
• Niski (Weak)
Wykorzystuje Szybką (Quick) opcję skanowania wirusów, wirusy usuwalne zostaną usunięte, wirusy nieusuwalne zostaną pominięte.
• Ustawienia własne (Custom settings)
Tej opcji nie można wybrać, będzie on uaktywniona, jeśli na panelu Ustawienia zaawansowane (Advanced settings) zostanie utworzona kombinacja ustawień, która nie występuje na żadnym z predefiniowanych poziomów.

Ustawienia zaawansowane (Advanced settings)

Po zaznaczeniu (kliknięciem) okienek wyboru znajdujących się obok nazwy aplikacji na panelu Zaawansowane (Advanced) w oknie Aplikacje chronione (Protected applications), uruchomi się ochrona rezydentna aplikacji. Niezaznaczone aplikacje nie będą chronione.
Komunikację pomiędzy oprogramowaniem a użytkownikiem, oraz poziom tej komunikacji, możesz ustawić przy pomocy opcji Poziom komunikacji (Communication level):
• Operacja automatyczna (Automatic operation)
Ochrona automatycznie, bez udziału użytkownika, wykona ustawione działania oraz przeprowadzi proces usuwania wirusów.
• Pokaż ostrzeżenie (Display warning message)
Ochrona automatycznie wykona ustawione działania i powiadomi o tym użytkownika.
• Komunikacja interaktywna (Interactive communication)
W przypadku wykrycia wirusa pojawi się komunikat, użytkownik będzie mógł podjąć decyzje, co do działań, które należy wykonać (domyślnie, oprogramowanie przedstawi propozycję działań w oparciu o ustawienia ochrony).
Opis ustawień W przypadku znalezienia wirusa (Virus found settings) znajduje się w części zatytułowanej Skaner! W przypadku znalezienia wirusa dostępne są następujące operacje:
• Zniszcz/Pomiń/Przemianuj/Poddaj kwarantannie/Usuń (Kill/Skip/Rename/Move to quarantine/Delete)
W przypadku wykrycia wirusa w wyniku analizy heurystycznej możliwe są następujące działania drugorzędne:


Ochrona MS Outlook (MS Outlook protection)

Komponent ten zapewnia ochronę klientowi pocztowemu MS Outlook. Komponent skanuje wszystkie wiadomości przychodzące zgodnie z ustawieniami i zapewnia stałą ochronę. Ustawienia komponentu można zmodyfikować na konsoli VirusBuster’a, jednak w celu przeprowadzenia pełnej konfiguracji należy również zapoznać się z modułem zintegrowanym z klientem MS Outlook.

Ustawienia konsoli VirusBuster’a

Ustawienia można zmodyfikować na następujących panelach:
• Ustawienia (Settings)
• Ustawienia skanowania (Scan settings)

Ustawienia (Settings)

Ustawienia ochrony można zmodyfikować na panelu Ustawienia (Settings). Właściwości Ochrony MS Outlook można zmodyfikować na panelu ustawień prostych lub na panelu ustawień zaawansowanych, na którym znajdują się bardziej szczegółowe opcje. W celu przejścia do panelu zaawansowanego kliknij na przycisk |Zaawansowane| (Advanced).
Ustawienia proste (Simple settings)
Ochrona jest aktywna, jeśli zaznaczona jest opcja Aktywna (Active). Istnieją trzy alternatywne poziomy ochrony, które możesz z łatwością wybrać zaznaczając jeden z nich. Poziomy te to domyślne zestawy ustawień, każdy z nich możesz zmodyfikować po kliknięciu na przycisk |Zaawansowane| (Advanced).
Poziomy ochrony oraz ich działanie są takie same jak opisano w części zatytułowanej Moduł ochrony MS Office.
Ustawienia zaawansowane (Advanced settings)
Jeśli włączona jest opcja Zezwól na otwieranie zainfekowanej poczty (Allow opening infected mail) (opcja jest zaznaczona), możliwe jest oglądanie w programie klienckim zawartości wiadomości pocztowych, których załączniki są zainfekowane. Jeśli opcja ta nie jest włączona, oglądanie wiadomości pocztowych, których załączniki są zainfekowane nie jest możliwe.
Opis ustawień W przypadku znalezienia wirusa (Virus found settings) znajdziesz w części zatytułowanej Skaner! W przypadku znalezienia wirusa dostępne są następujące operacje:
• Zniszcz/Pomiń/Przemianuj załącznik/Poddaj kwarantannie/Usuń załącznik ( Kill/Skip/Rename attachment/Move to quarantine/Delete attachment )
W przypadku wykrycia wirusa w wyniku analizy heurystycznej dostępne są następujące operacje i ustawienia drugorzędne:
• Pomiń/Przemianuj załącznik/Poddaj kwarantannie/Usuń załącznik ( Skip/Rename attachment/Move to quarantine/Delete attachment )

Ustawienia skanowania

Na tym panelu możesz zmodyfikować opcje skanowania oraz dokonać szczegółowych ustawień.

Po włączeniu Komunikacji interaktywnej (Interactive communication) oprogramowanie będzie nawiązywało kontakt z użytkownikiem ilekroć wystąpi incydent, oraz będzie proponowało operacje domyślne. Jeśli opcja ta jest wyłączona, operacje domyślne zostaną automatycznie wykonane na zainfekowanym pliku, użytkownik nie zostanie o tym poinformowany.
Po włączeniu opcji Skanowanie w archiwach (Scanning in compressed files), oprogramowanie będzie skanowało antywirusowo archiwa.
Po włączeniu opcji Skanowanie automatyczne przy uruchomieniu (Automatic scanning at startup), ochrona będzie rozpoczynała skanowanie antywirusowe po każdym uruchomieniu MS Outlook’a, oraz przeprowadzała skanowanie antywirusowe na każdej nowej, nieskanowanej wiadomości pocztowej.

Ustawienia w kliencie MS Outlook

Ustawienia znajdują się w menu Narzędzia/Opcje (Tools/Options) MS Outlook’a, na zakładce Ochrona MS Outlook (MS Outlook protection).

Ustawienia ogólne (General settings)

Na tym panelu znajdują się ustawienia ogólne oraz informacje podstawowe.
Dziennik (Log)
Po kliknięciu na przycisk |Przeglądaj dziennik| (View log), pojawi się komponent dziennika VirusBuster’a, w którym można przeglądać komunikaty zapisane w dzienniku.
Funkcjonalność (Functionality)
Tu można ustawić poziom komunikacji ochrony:
• Tryb interaktywny (Interactive mode)
Jeśli wybrano tę opcję, w przypadku wykrycia wirusa oprogramowanie zwraca się do użytkownika po dalsze instrukcje.
• Tryb automatyczny (Automatic operation)
Oprogramowanie nie zwraca się do użytkownika, przeprowadza działania zgodnie z ustawieniami.
Rejestracja (Registration)
Na tej części panelu wyświetla się status rejestracji. Po kliknięciu na przycisk |Rejestracja| (Registration), pojawi się okno rejestracji, w którym można wybrać potrzebny produkt VirusBuster’a i zarejestrować go przy pomocy danych rejestracyjnych.
Baza danych wirusów (Virus database)
Data i numer wersji bazy danych wirusów. Informacje można aktualizować klikając na przycisk |Odśwież| (Refresh).

Ustawienia skanowania (Scan settings)

Tu można ustawić opcje skanowania inicjowanego przez użytkownika (łącznie z automatycznym skanowaniem przy uruchomieniu).
Opcje skanowania (Scan options)
• Skanowanie automatyczne przy uruchomieniu (Automatic scanning at startup)
Po włączeniu tej opcji, po każdym uruchomieniu Outlooka oprogramowanie będzie skanowało wszystkie wiadomości, które nie były wcześniej skanowane.
• Skanowanie w archiwach (Scanning in compressed files)
Po włączeniu tej opcji, oprogramowanie będzie skanowało archiwa.
Ustawienia W przypadku znalezienia wirusa (Virus found settings)
Opis ustawień W przypadku znalezienia wirusa (Virus found settings) znajdziesz w części zatytułowanej Skaner! W przypadku znalezienia wirusa dostępne są następujące operacje:
• Zniszcz/Pomiń/Przemianuj załącznik/Poddaj kwarantannie/Usuń załącznik ( Kill/Skip/Rename attachment/Move to quarantine/Delete attachment )
W przypadku wykrycia wirusa w wyniku analizy heurystycznej dostępne są następujące operacje i ustawienia drugorzędne:
• Pomiń/Przemianuj załącznik/Poddaj kwarantannie/Usuń załącznik ( Skip/Rename attachment/Move to quarantine/Delete attachment )

Ustawienia ochrony rezydentnej MS Outlook (MS Outlook resident protection settings)

Jeśli włączona jest Ochrona rezydentna (Resident protection), oprogramowanie będzie przeprowadzało skanowanie przy każdej próbie dostępu do poczty (odczyt, stworzenie nowej wiadomości). Dostępne są następujące opcje skanowania wirusów:
• Skanowanie w archiwach (Scanning in compressed files)
Po wybraniu tej funkcji, oprogramowanie przeprowadzi skanowanie skompresowanych załączników.
• Otwórz zainfekowany list (Open infected mail)
Jeśli opcja ta jest włączona, oprogramowanie nie pozwoli użytkownikowi otworzyć wiadomości pocztowej, jeśli zawiera ona zainfekowany załącznik.
• Otwórz zainfekowany załącznik (Open infected attachment)
Jeśli opcja ta jest włączona, oprogramowanie nie pozwoli użytkownikowi otworzyć załącznika, jeśli jest on zainfekowany.
• Dołącz zainfekowany plik (Attach infected file)
Po wybraniu tej funkcji, oprogramowanie nie pozwoli użytkownikowi dołączyć zainfekowanego pliku do wiadomości pocztowej.
Operacje kontrolowane:
• Wiadomości odebrane (Received mails)
Jeśli opcja ta jest włączona, oprogramowanie będzie przeprowadzało skanowanie wszystkich wiadomości przychodzących.
• Wiadomości wysłane (Sent mails)
Jeśli opcja ta jest włączona, oprogramowanie będzie przeprowadzało skanowanie wszystkich wiadomości wychodzących.
• Wiadomości otwarte (Opened mails)
Jeśli opcja ta jest włączona, oprogramowanie będzie przeprowadzało skanowanie wszystkich otwartych wiadomości.
• Wiadomości zmodyfikowane (Modified mails)
Jeśli opcja ta jest włączona, oprogramowanie będzie przeprowadzało skanowanie wszystkich zmodyfikowanych wiadomości, łącznie z wiadomościami wysłanymi ponownie.
• Zawarte załączniki (Inserted attachments)
Jeśli opcja ta jest włączona, oprogramowanie będzie przeprowadzało skanowanie wszystkich plików (załączników) podczas dołączania ich do wiadomości.
W części ustawień W przypadku znalezienia wirusa można wybrać te same ustawienia, co w części Znaleziono wirus (Virus found) na panelu Ustawienia skanowania (Scan settings).

Skanowanie wiadomości pocztowych

Po wybraniu opcji Narzędzia/Pełne skanowanie (Tools/Full scan) lub Narzędzia/Skanowanie wybranych wiadomości (Tools/Scan selected e-mails) w MS Outlook’u, możliwe będzie skanowanie wszystkich lub wybranych wiadomości.
Okno wyświetlane w trakcie skanowania zawiera następujące informacje:
• Informacje o skanowaniu wirusów (Virus scan information)
Tu wyświetlają się informacje o liczbie skanowanych wiadomości, liczbie wykrytych wirusów, podejrzanych plikach, odkażonych załącznikach, oraz o ostatnim wykrytym wirusie.
• Informacje o skanowaniu (Scanning information)
Informuje użytkownika o folderze, w którym wykonywane jest skanowanie, o nadawcy wiadomości, oraz o jej temacie.
• Dziennik informacji (Log information)
Tu wyświetla się lista wykrytych wirusów.
Jeśli nie wykryto żadnych wirusów, po zakończeniu skanowania okno zostanie automatycznie zamknięte. W przypadku wykrycia wirusa, okno można zamknąć klikając na przycisk |OK|.


Modul kwarantanny (Quarantine)

Zadaniem tego komponentu jest przechowywanie oraz przetwarzanie zainfekowanych plików, z których nie można usunąć wirusów korzystając ze zdefiniowanych ustawień. Ustawienia kwarantanny można zmodyfikować na następujących panelach:
• Elementy (Items)
• Ustawienia (Settings)

Elementy

Lista zatytułowana Wpisy (Entries) zawiera informacje o wszystkich plikach poddawanych kwarantannie.
W oknie kwarantanny wyświetlają się następujące informacje:
• Nazwa (Name)
Oryginalna nazwa pliku
• Oryginalna ścieżka (Original path)
Oryginalna ścieżka pliku zanim został on poddany kwarantannie.
• Nazwa wirusa (Virus name)
Nazwa wirusa, który zainfekował plik.
• Data kwarantanny (Quarantine Date)
Data rozpoczęcia kwarantanny pliku.
Na plikach poddawanych kwarantannie można przeprowadzić kilka operacji, operacje te można uruchomić klikając na przyciski znajdujące się na dole panelu.
• |Skanuj ponownie| (Rescan)
Oprogramowanie przeprowadza dodatkowe skanowanie wybranego pliku/plików i, jeśli jest to możliwe, usuwa wirus.
• |Przywróć| (Restore)
Po uruchomieniu opcji Przywróć zainfekowane pliki (Restore infected files) na panelu Ustawienia (Settings) komponentu, oprogramowanie przywraca plik do jego oryginalnej lokacji i stanu, jednak jest to możliwe tylko w przypadku, gdy plik jest zainfekowany, jego oryginalny katalog istnieje, i nie znajduje się w nim żaden plik o takiej samej nazwie. Jeśli w oryginalnym katalogu można odnaleźć plik o takiej samej nazwie, lub katalog ten nie istnieje, kwarantanna przywróci plik do katalogu tymczasowego.
• |Zapisz jako...| (Save as...)
Zapisuje plik pod wybraną nazwą. Oprogramowanie szyfruje plik w celu uniemożliwienia aktywacji wirusa, plik może zostać przesłany do analizy antywirusowej.
• |Wyślij| (Send)
Przesyła wybrany plik do VirusBuster’a w celu poddania go analizie. Opcja ta działa tylko, jeśli ustawienia SMTP w komponencie Mailer są prawidłowe. Klikając ten przycisk możesz wysłać komunikat poprzez Komponent Mailer.
• |Usuń| (Delete)
Program trwale usuwa wybrany plik/pliki.
• |Odśwież | (Refresh)
Odświeża listę elementów poddanych kwarantannie.

Ustawienia (Settings)

Inne ustawienia kwarantanny znajdziesz na poniższym panelu:
Po włączeniu opcji Przywróć zainfekowane pliki (Restore infected files), możesz na zainfekowanych plikach zastosować funkcję przywracania, a przycisk |Przywróć| (Restore) znajdujący się na panelu Wpisy (Entries) staje się aktywny.
• Automatyczne ponowne skanowanie po aktualizacji bazy danych wirusów (Automatic rescan after virus database has been updated)
Jeśli zaznaczysz tę opcję, po każdej aktualizacji bazy danych wirusów oprogramowanie przeprowadzi ponowne skanowanie każdego pliku poddawanego kwarantannie i, jeśli jest to możliwe, usunie wszystkie wirusy.
• Automatyczne usuwanie usuwalnych wirusów (Automatic killing of killable viruses)
Jeśli zaznaczysz tę opcję, wirusy, które mogą zostać unieszkodliwione po aktualizacji bazy danych wirusów zostaną automatycznie usunięte z plików poddawanych kwarantannie. Opcję tę możesz zaznaczysz tylko po uprzednim zaznaczeniu opcji Automatyczne ponowne skanowanie po aktualizacji bazy danych wirusów (Automatic rescan after virus database updates).
• Automatyczne przywrócenie odkażonych plików (Automatic restoration of disinfected files)
Jeśli zaznaczysz tę opcję, oprogramowanie przywróci wszystkie pliki, które zostały automatycznie odkażone po aktualizacji bazy danych wirusów. Opcję tę możesz zaznaczyć tylko po uprzednim zaznaczeniu opcji Automatyczne ponowne skanowanie po aktualizacji bazy danych wirusów (Automatic rescan after virus database updates).
Uwaga!
Nie ma potrzeby podawania ścieżki do katalogu kwarantanny, oprogramowanie wykorzysta podkatalog Quarantine znajdujący się w katalogu instalacyjnym.


Komponent Dziennik zdarzeń (Log)

Jego główna funkcja to przechowywanie komunikatów wygenerowanych przez różne części (moduły) oprogramowania oraz, jeśli jest to konieczne, przekazywanie ich użytkownikowi.
W celu obejrzenia wpisów i zmiany ustawień należy wybrać następujące punkty z menu:
• Wpisy
• Ustawienia

Wpisy

Korzystając z komunikatów dziennika możesz prześledzić działanie ochrony antywirusowej lub wykryć przyczynę wystąpienia ewentualnego błędu, a także obejrzeć inne komunikaty programu.
Na panelu Wpisy dziennika (Log entries) wyświetlane są następujące informacje:
• Moduł (Module)
Nazwa modułu, który wygenerował komunikat
• Data (Date)
Data wygenerowania komunikatu
• Komputer (Machine)
Nazwa komputera gdzie został stworzony komunikat.
• Użytkownik (User)
Nazwa użytkownika, który uruchomił aplikację, która wygenerowała komunikat.
Oprogramowanie automatycznie odświeża listę, gdy zostaje wygenerowany nowy komunikat, lub gdy komunikat zostaje usunięty. Odświeżenie nie powoduje modyfikacji wybranego wpisu, o ile nie jest to wpis właśnie usunięty z listy.
Po kliknięciu prawym klawiszem myszy na panel z listą pojawi się pop-up menu, w którym można włączyć lub wyłączyć różne pola komunikatów, albo przeprowadzić następujące operacje:
• Zachowaj dziennik... (Save log...)
Zachowuje komunikaty w żądanym pliku.
• Wyślij... (Send...)
Wysyła pliki komunikatów i logów do pracowników wsparcia technicznego VirusBuster’a. Po wybraniu tej opcji możesz wysłać komunikat z okna komponentu Mailer (jeśli jest on zainstalowany).
• Odśwież (Reload)
Odświeża listę.
• Usuń (Delete)
Usuwa !wszystkie! wiadomości z listy.
Po dwukrotnym kliknięciu na wpis lewym klawiszem myszy pojawią się szczegóły komunikatu i można obejrzeć całą zawartość komunikatu.

Ustawienia

Na tym panelu można zmodyfikować ustawienia wyświetlania i zarządzania wpisami dziennika.
Wpisy dziennika można ustawić w porządku chronologicznym wybierając odpowiednią opcję, można także zmniejszyć rozmiar pliku dziennika:
• Usuwanie automatyczne (Automatic emptying)
Wpisy starsze niż ustalona wartość (w dniach) będą automatycznie usuwane z bazy danych.
• Wielkość bazy danych (Database size)
Tu można ustalić limit wielkości pliku dziennika (w MB). Plik dziennika nie przekroczy tego limitu, gdyż stare wpisy dziennika będą automatycznie usuwane.


Administracja (Administration)

Na panelu Administracja (Administration) Administratorzy mogą zablokować możliwość modyfikacji głównych ustawień, będą także uprawnieni do ustawienia dodatkowych opcji w celu dostosowania działania programu do własnych potrzeb. Administrator może ustawić hasło, aby ograniczyć dostęp do ustawień głównych aplikacji: tym sposobem tylko upoważnieni użytkownicy będą mogli zmodyfikować wartości ważnych opcji oraz ustawienia Administratora.

Klikając na menu Administracja w celu uzyskania dostępu do panelu administratora oraz możliwości modyfikacji wartości “zamkniętych”/zablokowanych opcji musisz podać swoje hasło, jeśli zostało ono ustalone wcześniej. Wpisz swoje hasło w polu Hasło (Password), a następnie kliknij na przycisk |OK| aby dostać się do ustawień administracji (Tryb Admin).

Jeżeli nie ustalono hasła, użytkownicy mogą modyfikować wszystkie ustawienia. Kliknij na przycisk |Ustaw hasło| (Set password) w celu ustawienia swojego hasła Administratora na panelu Ustawienia dostępu (Access settings).
W zależności od faktu czy ustawione jest hasło dla produktu, czy nie oraz czy użytkownik jest już zalogowany do produktu, czy nie, może on być używany w 2 następujących trybach:
• Tryb Admin: użytkownik zalogowany na panelu Admin produktu (jest to pokazane jako mały symbol kłódki na pasku menu).
• Tryb normalny: nie ma potrzeby wpisywania hasła, aby dostać się do panelu administracyjnego albo użytkownik nie zgłosił jeszcze swojego hasła do produktu (w takim przypadku brak jest symboku kłódki lub -jeśli to drugie- jest to pokazane jako już zablokowane).

Ustawienia dostępu (Access settings)

Jeśli dla produktu nie ustawiono hasła, na tym panelu dostępny jest tylko |Ustaw hasło| (Set password) służący do ustawiania hasła. Po ustawieniu hasła, modyfikacja niektórych ważnych opcji programu nie będzie możliwa bez uprzedniego wprowadzenia ustawionego hasła (Tryb Admin), w rezultacie nieupoważnieni użytkownicy nie będą w stanie zmienić ważnych ustawień programu.
Jeżeli ustawiłeś swoje hasło administratora, na panelu tym dostępne będą następujące opcje:
• Zmień hasło (Change password)
• Wyloguj (Logout)
• Skasuj hasło (Delete password)

Ustawienia ogólne

Możesz kontrolować ogólne działanie programu włączając/wyłączając różne funkcje.
Opcje Pasek Zadań (System Tray) pozwalają ci dostosować działanie menu menu Paska Zadań i okienek wyskakujących do twoich potrzeb.
• Wyłącz menu w Pasku Zadań (Disable System Tray menu)
Jeśli wybierzesz tę opcję, menu lokalne ikony z Paska Zadań nie wyświetli się nawet po kliknięciu na ikonę prawym klawiszem myszy.
• Wyłącz ikonę na Pasku Zadań (Disable System Tray icon)
Po wybraniu tej opcji ikona na Pasku Zadań nie będzie wyświetlana.
• Wyłącz okienka wyskakujące (Disable Pop-up messages)
Aplikacja nie będzie ostrzegała użytkownika, przy pomocy okienek wyskakujących (wyświetlanych nad Paskiem Zadań), o problemach i zdarzeniach, które wystąpiły w trakcie trwania operacji. Ustawienie to nie ma wpływu na wyświetlanie innych okien informacyjnych (alarmów wirusowych, ostrzeżeń) programu.

Jeżeli, z powodów bezpieczeństwa, chcesz zablokować dostęp do pliku pomocy, zaznacz opcję w grupie Inne ustawienia (Other setting)! Jeśli zablokujesz Pomoc, użytkownicy nie będą mogli wyświetlić pliku pomocy klikając na przycisk |Pomoc| (Help) na interfejsie.

Możesz zmienić język aplikacji poprzez wybór z Ustawień Języka. Następnie należy ponownie uruchomić aplikację. Aby zmiana języka przyniosła efekt również w podajniku- należy restartować komputer.

Ustawienia Mailera

To menu jest dostępne tylko wtedy, gdy zainstalowano komponent Mailera. Można tu ustawić kilka parametrów wysyłki potrzebnych do przesyłania komunikatów. Zobacz rozdział Mailer, aby uzyskać więcej informacji.

Alarm Centralny

Alarm Centralny to funkcja przydatna administratorom, którzy chcieliby być informowani o różnych zdarzeniach, jakie wystąpiły na komputerach klienckich. Jedyna rzecz, jaką powinien zrobić administrator to podanie typu zdarzenia o jakim ma być informowany i ustawienie adresu e-mail.
Aby uruchomić funkcję Alarmu Centralnego włącz Powiadomienie e-mail (Message sending). W ramach tego wybierz typy zdarzeń, o jakich chcesz być informowany. Dostępne są poniższe typy:
• Znaleziono wirus(*)
Znaleziono zainfekowany plik.
• Podejrzany plik
Znaleziono podejrzany plik.
• Zmiana konfiguracji(*)
Może być wygenerowany gdy zmieni się ustawienie/konfiguracja produktu.
• Naruszenie wyjątku
Po detekcji naruszenia wyjątku.
• Ostrzeżenie
Może być wygenerowany kiedy nie działa jeden z komponentów lub nastąpił się inny, mniej groźny błąd.
• Potwierdzenie
Raport o wykonanych akcjach i zadaniach.
• Komunikat
Komunikat informacyjny o systemie antywirusowym.
• Błąd
Zadania lub akcja nie mogła być wykonana lub nie została zdefiniowana, itp.
• Błąd krytyczny (*)
Poważny, krytyczny błąd systemu i jego zagrożenia dla poprawnych operacji.
• Bezpieczeństwo (*)
Problem z bazą antywirusową, na przykład: niekompatybilna wersja, inne ostrzeżenia bezpieczeństwa.

Na dole panelu wprowadź poprawny adres e-mail, na który mają być przekazywane komunikaty z VirusBuster. Użyj przycisku Przeglądaj |Browse ...| aby wybrać adres z kontaktów.

Wybór Wyślij dokładną wiadomość (Send detailed message) pozwoli otrzymywać komunikaty w bardziej szczegółowej postaci, z większą ilością danych.

Zarządzanie prawami

Zarządzanie Prawami otwiera wydajne opcje specyfikacji dostępu i kontroli praw do każdego zainstalowanego modułu. Dostępność zależy od tego, czy produkt jest używany w trybie Admin (Admin mode) czy w trybie normalnym (Normal mode).
Uwaga!
Tryb jest nazywany trybem Admin (Admin mode), co nie jest równoważne z prawami Administratora systemu operacyjnego Windows. Tryb Admin oznacza, że użytkownik ma prawa wyższego poziomu do kontroli ustawień modułów w aplikacji antywirusowej.

Jest możliwość ograniczenia niektórych operacji (np. uruchamianie zadań) lub blokowania ustawień modułów na wypadek prób zmiany.

Na środku panelu znajduje się okno z dwoma kolumnami. Pierwsza zawiera zainstalowane komponenty (Component), druga zawiera prawa dostępu właściwe każdemu modułowi (Access). Wymagane ustawienia mogą być wybierane z rozwijanej listy wyboru.
Do ustawień poszczególnych modułów można nadawać następujące dostępy:
• Ukryty
Ustawienia modułu będą niedostępne zarówno w trybie Admin, jak i Normal dopóki modułowi nadano tą wartość.
• Widoczny w trybie Admin, ale bez możliwości kontroli
Ustawienia modułu są widoczne tylko w trybie Admin, ale nie ma możliwości ich ustawiania nawet w trybie Admin.
• Widoczny w trybie Admin, z możliwością kontroli
Ustawienia modułu są widoczne i kontrolowane tylko w trybie Admin.
• Zawsze widoczny, ale bez możliwości kontroli
Ustawienia modułu są widoczne w obu trybach: Admin i Normal, ale nie ma możliwości ich ustawiania.
• Zawsze widoczny, z możliwością kontroli w trybie Admin
Ustawienia modułu są widoczne w obu trybach: Admin i Normal, ale kontrolowane tylko w trybie Admin.
• Bez ograniczeń
Uwaga!
Jeśli nie ustawiono hasła do produktu, wartość Ukryty ma wpływ na cały system. Celowe jest wybranie innej opcji, która w tym momencie nie ma działania (ponieważ zależy od zalogowanych/wylogowanych użytkowników).
Jeśli ograniczony jest dostęp do Skanowania lub Aktualizacji, a w danym przypadku aktualne zadania modułów nie są dostępne inaczej, nie mogą być one uruchomione ręcznie (jak również oczywiście nie zostaną uruchomione poprzez funkcję Harmonogramu zadań). Możesz jednak wybrać z listy Ustawień i Użytkowników Autoryzowanych do startu zadania tych, którzy poprzez przynależność do wybranej kategorii będą mogli uruchomić ręcznie zadanie, pomimo nałożonych ograniczeń.
• Każdy
Każdy użytkownik może ręcznie uruchomić zadanie w produkcie.
• Zalogowany Administrator
Ktoś, kto używa produkt w trybie Admin może uruchomić zadanie ręcznie (jeśli to nie jest zabronione, użytkownicy w trybie Noraml też mogą to wykonać).
• Nikt
Nikt nie może uruchomić zadania ręcznie (jeśli zabroniono, użytkownicy nie mogą tego zrobić).

Aktywacja

Menu Aktywacja jest widoczne tylko wtedy, jeśli produkt został zarejestrowany poprzez proces aktywacji. W tym przypadku na tym panelu możesz deaktywować produkt oraz sprawdzać lub zmieniać swoje dane aktywacyjne i ustawienia sieci w przypadku problemów z połączeniem.

Możesz uruchomić proces aktywacji klikając na przycisk |Aktywacja...| na dole panelu. W przypadku produktu już aktywowanego jest to potrzebne tylko podczas zmian danych aktywacyjnych (najczęściej adres e-mail) lub jeśli aktywacja produktu wygasła i zamierzasz go reaktywować ręcznie. Aktualny stan aktywacji widać obok klawisza.

Aby zmienić dane aktywacyjne, musisz podać nowy adres e-mail i/lub nowy klucz aktywacji oraz rozpocząć proces aktywacji przyciskiem |Aktywacja...|. Po udanej aktywacji zmienione dane zostaną zapisane i produkt będzie zarejestrowany z dostarczonym kodem aktywacji.
W przypadku aktywacji nieudanej z powodu problemu połączenia, można zmienić ustawienia proxy. Dostępne są poniższe opcje:
• Połączenie internetowe bez Proxy
Program nie używa proxy.
• Wykorzystanie ustawienień systemowych dla połączenia z Internetem
Program używa ustawienia systemu operacyjnego
• Ręczne ustawienia Proxy
Użytkownik może ręcznie ustawić proxy.
Uwaga!
Modyfikacja domyślnych ustawień proxy jest zalecana użytkownikom zaawansowanym!


Wysyłanie wiadomości (Mailer)

Jeżeli masz pytanie lub prośbę, możliwe jest wysłanie z programu bezpośredniej wiadomości do VirusBuster’a.

Dostęp do komponentu Mailer można uzyskać z Paska Zadań (kliknij prawym klawiszem myszy na ikonę VirusBuster’a i wybierz opcję Wsparcie/Skontaktuj się (Support/Contact us)), lub z komponentów Dziennik zdarzeń albo Kwarantanna.
Wysyłanie dziennika zdarzeń
Gdy wysyłasz dziennik zdarzeń albo elementy wybrane z poddanych kwarantannie, pojawi się okno informacyjne. W jego górnej części wyświetlają się dane nadawcy. Dane te, które są określane przez wysyłającego, można zmienić – wraz z ustawieniami SMTP – klikając na przycisk |Ustawienia Mailer’a ...| (Mailer settings ...). Następujące pola muszą zostać wypełnione na panelu (określenie odpowiednich ustawień SMTP jest podstawą funkcjonowania Mailer’a):
• Serwer SMTP (SMTP server)
Nazwa serwera rozsyłającego e-maile, zwykle nazwa ta jest podawana przez ISP (Dostawcę Usług Internetowych) lub jest to nazwa serwera Exchange (informacje te można znaleźć w ustawieniach klienta mailer’a /Outlook, Thunderbird, etc/, możesz także zapytać swojego administratora systemu lub ISP (Dostawcę Usług Internetowych)).
• Numer portu (Port number)
Numer portu serwera pocztowego (w większości przypadków jest to 25).
• Nazwa użytkownika (User name)
W mailu, którego do nas wyślesz, nazwa ta wyświetli się jako ‘nadawca’.
• Adres e-mail (E-mail address)
Jest to twój adres pocztowy, pod który wysłana zostanie odpowiedź.
W centrum panelu, w części zatytułowanej Informacje o liście (Mail information), wyświetla się nagłówek wiadomości, która zostanie wysłana nie można go jednak edytować. Adresatem jest dział wsparcia technicznego VirusBuster’a. Tu wyświetla się temat wiadomości i załączone pliki: w przypadku przesyłania dziennika, wyświetla się nazwa załączonego pliku dziennika, w przypadku przesyłania plików poddawanych kwarantannie – odnośnik do załączonych plików. Musisz wypełnić pole tekstowe Komentarze (Comments), w nim możesz opisać swój problem, wpisać pytania oraz komentarze.

Wiadomość możesz wysłać wciskając przycisk |OK|. Proces możesz przerwać klikając na przycisk |Anuluj| (Cancel).


Metody skanowania wirusów

Motor skanowania wirusów może skanować i wykrywać wirusy w oparciu o ustawione metody skanowania. Wyboru stosownej metody skanowania można dokonać w komponentach programu. Dostępne są następujące metody:
• Szybka (Quick)
Skanuje tylko te części pliku, w których prawdopodobieństwo wystąpienia wirusów jest największe, nie wykrywa wirusów, których wykrycie wymaga zastosowania większej ilości zasobów systemowych (np. wirusy w formułach Excel’a).
• Rozległa (Extensive)
Zoptymalizowana metoda skanowania, wykrywa wszystkie wirusy zarejestrowane w bazie danych wirusów, skanuje te części pliku, w których prawdopodobieństwo wystąpienia wirusów jest największe.
• Pełna (Full)
Wykrywa wszystkie wirusy zarejestrowane w bazie danych wirusów i skanuje cały plik, nawet te jego części, w których prawdopodobieństwo wykrycia wirusów nie jest duże.


Heurystyka

W trakcie analizy heurystycznej oprogramowanie próbuje wykryć kody i programy, które mają “wirusopodobne” cechy, ale nie są zarejestrowane w bazie danych wirusów. W przypadku odnalezienia podejrzanego pliku, użytkownik zostaje o tym powiadomiony. Dostępne są następujące poziomy analizy heurystycznej:
• Wyłączona (Disabled)
Brak analizy heurystycznej.
• Normalna (Normal)
Głębokość analizy jest ograniczona, prawdopodobieństwo fałszywego alarmu jest niskie, jednak szanse wykrycia nieznanych wirusów nie są zbyt wielkie.
• Silna (Strong)
Szansa wykrycia nieznanych wirusów jest większa, jednak istnieje większe prawdopodobieństwo fałszywego alarmu.


Operacje

W przypadku wystąpienia infekcji wirusowej, na zainfekowanym pliku można przeprowadzić kilka operacji. Dostępne są następujące operacje:
• Zniszcz (Kill)
Usuwa wirus z zainfekowanego pliku, plik zostanie odkażony i przywrócony do stanu początkowego.
• Poddaj kwarantannie (Move to quarantine)
Przesuwa plik do katalogu kwarantanny. Wirusy przesunięte do katalogu kwarantanny nie są aktywne, nie są niebezpieczne dla systemu.
• Pomiń (Skip)
Na zainfekowanym pliku nie jest przeprowadzana żadna operacja.
• Usuń (Delete)
Trwale usuwa zainfekowany plik.
• Przemianuj (Renami)
Zamienia pierwszą literę rozszerzenia zainfekowanego pliku na “v”.
Na załącznikach wiadomości pocztowych można przeprowadzić następujące operacje/działania:
• Usuń załącznik (Delete attachment)
Usuwa zainfekowany załącznik z wiadomości pocztowej.
• Przemianuj załącznik (Rename attachment)
Zamienia pierwszą literę rozszerzenia zainfekowanego załącznika na “w”.


Okona, komunikati

VirusBuster wyświetla swoje komunikaty i informacje w oknach komunikatów znajdujących się na ekranie, ma to na celu informowanie użytkownika o wirusach oraz o zdarzeniach, które zachodzą w systemie.

Okno skanowania wirusów

Po uruchomieniu skanowania wirusów, proces skanowania oraz jego parametry wyświetlają się w oknie, ma to na celu informowanie cię o statusie procesu skanowania.
Okno skanowania wirusów
W górnej części okna wyświetlają się główne ustawienia procesu skanowania oraz metoda skanowania i usuwania wirusów. W części zatytułowanej Proces skanowania (Scanning process) znajduje się nazwa pliku, który jest aktualnie skanowany, oraz jego ścieżka, informacje o upływie czasu oraz pasek wskaźnika statusu. W części zatytułowanej Statystyki skanowania (Scan statistics) znajdują się informacje o liczbie przeskanowanych plików, liczbie plików zainfekowanych, liczbie plików odkażonych, oraz liczbie plików podejrzanych. W części Ostatni znaleziony wirus (Last found wirus) wyświetlane są informacje o nazwie i ścieżce ostatnio wykrytego zainfekowanego pliku, zaś w polu Nazwa wirusa (Virus name) – informacje o ostatnim wykrytym wirusie. Wpisy dziennika, które zostały wygenerowane w trakcie procesu skanowania, wyświetlają się w oknie znajdującym się w dolnej części panelu. Dostęp do szczegółowych informacji o każdym z wpisów możesz uzyskać dwukrotnie klikając na dany element lewym klawiszem myszy.
Skanowanie antywirusowe można uruchomić na wiele sposobów, dlatego też wyświetlane okna skanowania zawierają generalnie te same informacje, aczkolwiek istnieją pewne różnice pomiędzy różnymi typami skanowania. Wspomniane powyżej informacje ogólne są zawsze wyświetlane, podczas gdy inne ustawienia i przyciski są wyświetlane w zależności od wybranej metody uruchomienia procesu skanowania.

Okno skanowania wirusów podczas zadania skanowania oraz podczas skanowania manualnego

W przypadku tych metod skanowania, okno skanowania wirusów nie jest wyświetlane jako osobne okno, jest ono wyświetlane w obrębie interfejsu konsoli. Nad informacjami podstawowymi dostępne są przyciski pozwalające kontrolować proces skanowania:
Możesz zakończyć process skanowania klikając przycisk |Anuluj| (Cancel) - spowoduje to powrót do listy zadań skanowania Zadania.
Podczas skanowania:
• |Stop| (Stop)
Możesz zatrzymać skanowanie w dowolnym momencie. Po zatrzymaniu skanowania, te przyciski będą dostępne, które normalnie są dostępne, gdy skanowanie jest zakończone.
• |Pauza| (Pause)
Jeśli użyta jest ta opcja, process skanowania zostaje wstrzymany, ale skanowanie można kontynuować klikając przycisk |Kontynuuj| (Continue).
Po skanowaniu:
• |Skanuj ponownie| (Rescan)
Ponownie uruchamia zadanie skanowania.
• |Zapisz jako ...| (Save as ...)
Zachowuje dziennik skanowania do pliku.
• |Dodaj| (Add) (Tylko w przypadku manualnego skanowania!)
Skanowanie ze zmodyfikowanymi ustawieniami może zostać zachowane jako zadanie skanowania, które może być później uruchomione jednym kliknięciem myszki. Aby utworzyć nowe zadanie musisz zdefiniować Harmonogram oraz Nazwę zadania.

Okno skanowania wirusów podczas szybkiego skanowania

W przypadku szybkiego skanowania pojawi się okno informujące użytkownika o stanie skanowania. Zaznaczenie opcji Zamknij okno automatycznie po zakończeniu operacji (Automatically close the window after the operation) na dole panelu spowoduje, iż okno skanowania wirusów zostanie automatycznie zamknięte po zakończeniu skanowania. To samo można uzyskać klikając przycisk |Zakończ| (Finish). Proces skanowania może zostać zatrzymany klikając przycisk |Stop|.

Okno komunikatu

Program używa okna komunikatu do wyświetlania informacji o wykrytych wirusach, rezultatach operacji podjętych przez użytkownika, lub innych problemach funkcjonalnych, które mogą wystąpić w systemie.

Komunikat o infekcji wirusowej

Podczas skanowania wirusów, jeśli napotkany jest zainfekowany plik, program wyświetla okno komunikatu.
Typy infekcji:
• Zainfekowany – wirus usuwalny
Silnik skanowania wirusów znalazł zainfekowany plik, z którego wirus może zostać usunięty.
• Zainfekowany – wirus nieusuwalny
Silnik skanowania wirusów znalazł wirus w pliku, ale nie posiada informacji w bazie danych o sposobie usunięcia wirusa.
• Podejrzany
Silnik skanowania wirusów znalazł plik podejrzany o zawieranie wirusa. Oznacza to, że plik ten zawiera kod, lub segment kodu, który wskazuje na obecność wirusa. Szczegółowe informacje na ten temat znajdują się w sekcji Heurystyka.
Okno Znaleziono wirus (Virus found) może być wyświetlane podczas pracy następujących modułów programu:
• Zadanie skanowania, podczas szybkiego skanowania
• Gdy aktywna jest Tarcza (bez interakcji z użytkownikiem)
• Ochrona MS Office
• Ochrona MS Outlook
• Ponowne skanowanie plików poddanych kwarantannie
Indywidualne ustawienia w przypadku znalezienia wirusa mogą zostać przypisane wszystkim powyższym modułom, a metoda usuwania wirusów może być zdefiniowana dla każdego z modułów oddzielnie.
Znaleziono wirus
W górnej części okna wyświetlana jest ikona i nazwa modułu, który wysłał komunikat. To informuje cię, który moduł wykrył wirusa. Czerwony pasek w środku informuje cię o rodzaju infekcji a wyżej wyświetlana jest informacja o metodzie usunięcia wirusa i możliwych działaniach. Pod czerwonym paskiem wyświetlana jest nazwa i ścieżka zainfekowanego pliku, a obok – jeśli tylko informacja ta jest dostępna – wyświetlana jest nazwa wirusa.
W dolnej części interaktywnego panelu znajdują się przyciski, za pomocą, których możesz zdefiniować operacje.
Program może wysyłać jedynie komunikat ostrzegawczy o incydentach wykrytych przez moduł Tarcza. Zainfekowane pliki będą traktowane zgodnie z ustawieniami w sekcji „W przypadku znalezienia wirusa” modułu.
Kliknięcie przycisku |X| w prawym górnym rogu okna spowoduje wykonanie operacji Pomiń (Skip) dla aktualnego incydentu.
Gdy zaznaczymy opcję Zastosuj do wszytkich (Apply to all), system nie wyświetli informacji o znalezieniu wirusów tego typu a zdefiniowane operacje będą automatycznie wykonywane w przypadku kolejnych wystąpień takich incydentów.

Ostrzeżenie

Te komunikaty dostarczają informacji o zmianach i wynikach operacji zainicjowanej przez użytkownika.
Ostrzeżenie
To okno jest podobne do okna “znaleziono wirusa”. W górnej części okna wyświetlana jest ikona i nazwa modułu, który wysłał komunikat. Pomarańczowy pasek zawiera tekst komunikatu a szczegółowy opis można przeczytać w oknie szczegółów, które można zobaczyć klikając na strzałkę z prawej strony paska Szczegóły (Details).
Przycisk |OK| służy do potwierdzania komunikatu I kontynuowania operacji. Jeśli na panelu dostępny jest przycisk |Anuluj| (Cancel), możesz użyć, go aby przerwać kontynuowanie rozpoczętego zadania.


Często zadawane pytania

Ogólne

• Jaka jest różnica między aktywacją a rejestracją?
Użytkownicy posiadający klucz aktywacji (3x4 znaki) mogą aktywować produkt za pośrednictwem poczty elektronicznej (e-mail) lub SMS-a. Klucz rejestracji (3x5 znaków) zostanie przesłany pod podany adres e-mail lub na podany numer telefonu SMS-em po dokonaniu aktywacji w wyżej opisany sposób.
Użytkownicy posiadający klucz rejestracji mogą zarejestrować produkt bezpośrednio poprzez wpisanie klucza rejestracji i nazwy użytkownika.
• Posiadam ważną licencję na starszą wersją VirusBuster’a. Czy mogę używać tych danych (nazwa użytkownika, klucz rejestracji) dla VirusBuster 2006?
Tak.
Twoje dotychczasowe dane rejestracyjne są dostępne również dla produktu VirusBuster 2006. Rejestracja nowego produktu – wersji 2006 – będzie możliwa dopóki dane rejestracyjne są ważne.
• Czy ten produkt chroni przed spyware i adware?
W większości przypadków programy te są ściągane z legalnych stron lub instalowane wraz z legalnymi produktami, przy udziale użytkownika. VirusBuster rozpoznaje takie adware/spyware, które są rozpowszechniane nielegalnie lub są bardziej kłopotliwe dla użytkownika.
Programy te zwykle integrują się z przeglądarką Internet Explorer, ich nieprawidłowe usunięcie może spowodować poważniejsze problemy niż ich obecność w systemie. VirusBuster wykrywa je jako aplikacje nieusuwalne. Zwykle zaleca się, by w celu ich usunięcia użytkownicy odinstalowali programy tego typu wykorzystując standardową funkcję Windows ‘Dodaj lub usuń programy’ (‘Add/Remove Programs’).

Instalacja/uaktualnianie

• VirusBuster nie aktualizuje się za pośrednictwem serwera ISA. Nie działa ani aktualizacja programu, ani aktualizacja bazy danych wirusów. Co robić?
Na komputerach wyposażonych w VirusBuster należy zainstalować aplikację ISA Firewall Client. Firewall Client jest w stanie nawiązać autoryzowane połączenie z serwerem ISA, w ten sposób funkcje aktualizacji będą mogły ściągnąć pliki za pośrednictwem serwera ISA. W celu uzyskania dalszych informacji, odwiedź stronę www.isaserver.org .
• Mam system WinXP SP2, wbudowany firewall jest włączony. Nie działa ani aktualizacja programu, ani aktualizacja bazy danych wirusów. Wyświetla się następujący kod błędu w dzienniku zdarzeń: 183. Co robić?
Taka sytuacja może wystąpić nie tylko w przypadku wbudowanego firewall’a Windows, ale również w przypadku innych firewall’i (np. Kerio, ZoneAlarm, Outpost, ...).
Rozwiązanie:
Po rozpoczęciu procesu aktualizacji, firewall poprosi o połączenie. W takim wypadku należy wybrać opcję "Unblock" (firewall WinXP SP2) lub pozwolić na połączenie (inne firewall’e).
• Co mam zrobić, gdy po rozpoczęciu instalacji pojawia się następujący komunikat o błędzie: 'Incompatible version of the RPC stub. Setup will now terminate.'?
Jeśli na twoim komputerze jest zainstalowany cały pakiet lub dowolny komponent pakietu Office 2000, zdobądź i zainstaluj Office 2000 Service Release 1a (SR-1a). W celu uzyskania informacji jak to zrobić, odwiedź stronę Microsoft o następującym adresie:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=AF6C8D03-7633-45B4-AB96-795EE656F2A2
Jeśli na twoim komputerze NIE jest zainstalowany cały pakiet lub dowolny komponent pakietu Office 2000, zdobądź i zainstaluj narzędzie 'Mcrepair.exe'. W celu uzyskania informacji jak to zrobić, odwiedź stronę Microsoft o podanym niżej adresie, zachowaj plik 'Mcrepair.exe' na pulpicie i uruchom ‘Mcrepair.exe':
http://download.microsoft.com/download/msninvestor/patch/1.0/win98/en-us/mcrepair.exe
Po zainstalowaniu 'Mcrepair.exe', ponownie uruchom komputer.
• Czy w tym produkcie są dostępne funkcje automatycznej aktualizacji bazy danych wirusów i wersji programu?
Tak.
W trakcie instalacji produktu zostaną zainstalowane dwa domyślne zadania aktualizacji (o ile nie postanowisz ich wyłączyć). Zadanie aktualizacji bazy danych wirusów będzie wykonywane codziennie, zadanie aktualizacji wersji programu będzie wykonywane domyślnie raz w tygodniu. Upewnij się, czy twoje połączenie z siecią jest dostępne, dopilnuj, by twój firewall nie zablokował połączenia modułu aktualizacyjnego z serwerem/lokacją będącą źródłem aktualizacji.
• Program instalacyjny zatrzymuje się i wyświetla się np. taki komunikat: "...msvcp60.dll not found...".
Jeśli jeden lub więcej redystrybuowalnych plików systemowych zaginęło lub zostało zniszczonych i dostajesz podobny komunikat o błędzie, użyj pakietu 'VirusBuster Redist Installer and Checker' w celu odzyskania potrzebnych plików.
W celu uzyskania dalszych informacji, skorzystaj z pliku readmeen.txt.
• W trakcie instalacji otrzymuję następujący komunikat o wystąpieniu błędu: "Error 1607: Unable to install installShield Scripting Runtime".
Jest to spowodowane brakiem wpisu w rejestrze, który zwykle jest tworzony podczas instalacji ISScript.msi w trakcie poprzedniego procesu instalacji, prawdopodobnie innego produktu.
Rozwiązanie:
W celu rozwiązania problemu należy zarejestrować plik o nazwie IDriver.exe
- Otwórz Windows Explorer i przejdź do następującej lokacji:
C:\Program Files\Common Files\InstallShield\Driver\7\Intel 32
- Przejdź do Start menu (Menu startowego) > komenda Run (Uruchom)
- Przeciągnij plik IDriver.exe do okna komendy “run” (uruchom)
- Wpisz parametr /regserver po IDriver.exe i wybierz |OK|.
- Spróbuj ponownie zainstalować aplikację
• Występują u mnie następujące kody błędów... Co robić?
Ustawienia nazwa użytkownika/hasło, które zostaną wymienione poniżej można znaleźć w następujących opcjach interfejsu użytkownika:
Interfejs MMC użytkownika:
(1) Konsola VirusBuster > Wspólne > Ustawienia ogólne > Kontekst bezpieczeństwa dla połączeń sieciowych dla użytkownika domyślnego.
(2) Ustawienie użytkownika może zostać ustalone dla zadań aktualizacji oraz dla zadań instalacyjno-kopiujących. Wybierz właściwość Harmonogram (Scheduling) wybranego zadania aktualizacji lub kopiującego, następnie znajdź ustawienia Własne (Custom) na panelu Bezpieczeństwo (Security). Domyślne i stworzone przez użytkownika zadania aktualizacji oraz zadania instalacyjno-kopiujące domyślnie wykorzystują wartość użytkownika domyślnego ustaloną w punkcie pierwszym (1).
Interfejs użytkownika typu kreator (wizard):
Ustawienia nazwa użytkownika/hasło dla zadania Aktualizacji są dostępne na panelu Harmonogram (Scheduling).
Kod błędu: 3
Sprawdź, czy wybrane ścieżki (aktualizacja, kopiowanie) są prawidłowe. Sprawdź, czy są one pełne i aktualne.
Kod błędu: 5 lub 65
Sprawdź, czy wybrany użytkownik (opisany poprzez ustawienia nazwa użytkownika/hasło) posiada odpowiednie prawa do danego pliku lub katalogu (musi posiadać przynajmniej prawo odczytu).
Kod błędu 65: ten sam błąd w sieci.
Kod błędu: 1326
Wybrany użytkownik (opisany poprzez ustawienia nazwa użytkownika/hasło) jest nieaktualny lub nie istnieje. Proszę sprawdzić jego dane – usunąć je i wprowadzić ponownie.

Użytkowanie

• Nie mogę zmodyfikować wartości niektórych ustawień... Dlaczego?
Prawdopodobnie w programie zostało ustawione hasło administratora, które ogranicza modyfikację niektórych ustawień. Jeśli wprowadzisz (lub usuniesz) hasło administratora, zmiana ustawień stanie się znów możliwa.
Rozwiązanie:
Kliknij na moduł Administracja (Administration) znajdujący się w z lewej strony interfejsu użytkownika i wprowadź ważne hasło!

Filtr zawartości

• Które aplikacje (klienci) są całkowicie kompatybilne z Filtrem zawartości?
Możesz używać Filtru zawartości dla kilku aplikacji klienckich. Oto aplikacje, które bez problemu współpracują z Filtrem zawartości:
Przeglądarki:
Internet Explorer 6.0
Opera 7.54
Mozilla FireFox 1.0
Netscape 7.2
Klienci FTP :
Total Commander 6.0
Far
Klienci poczty (POP3, IMAP, SMTP):
Outlook
Outlook Express
Mozilla Thunderbird
The Bat (z wyjątkiem IMAP)
Netscape
Pegasus Mail
Filtr Zawartości został przetestowany na wyżej wymienionych aplikacjach. Oczywiście Filtra zawartości można używać także dla innych aplikacji, jednak w przypadku aplikacji, które nie zostały przetestowane prawidłowe działanie filtra nie jest gwarantowane.
Filtr zawartości jest również dostępny dla menadżerów ściągania (download managers) jeśli używają one tylko jeden wątek w celu ściągnięcia danych!
• Co mam zrobić jeśli Filtr zawartości nie działa gdy używam Netscape?
Jeżeli funkcja Quick launch jest uruchamiana w przeglądarce (zaznaczona jest opcja ‘Edit/Preferences/Advanced/’Enable quick launch’), należy wyjść z Netscape po zainstalowaniu VirusBuster’a i ponownie go uruchomić, w celu umożliwienia działania Filtra zawartości i skanowania ruchu w Netscape.
Rozwiązanie:
Aby wyjść z Netscape, użyj ikony quick launch w zasobniku systemowym. Po zamknięciu okna Netscape, kliknij na ikonę prawym klawiszem myszy i wybierz ‘Wyjdź z Netscape’ (’Exit Netscape’) w menu.


KONTAKTY

Ten podręcznik zawiera wyczerpujące informacje o użytkowaniu naszych produktów ochrony antywirusowej. Jeśli masz jakieś dodatkowe pytania na ich temat lub chciałbyś podzielić się z nami swoimi doświadczeniami lub spostrzeżeniami, nie wahaj się skontaktować z nami! Zwróć się do nas, Twoje potrzeby i uwagi zostaną potraktowane z należytą starannością.
Adres | VirusBuster Ltd.
 | Budapest 1116,
 | Vegyesz u. 17-25.
 | Hungary
Telefon | (+36) 1 382-7000
Fax | (+36) 1 382-7007
Web | www.virusbuster.hu
Email | mail@virusbuster.hu


END USER AGREEMENT

THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT BETWEEN YOU AND VirusBuster Ltd. READ IT CAREFULLY BEFORE COMPLETING THE INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS THEN DO NOT INSTALL THE SOFTWARE.

IMPORTANT NOTICE TO USERS: THE SOFTWARE IS NOT FAULT-TOLERANT AND IS NOT DESIGNED OR INTENDED FOR USE IN ANY HAZARDOUS ENVIRONMENT REQUIRING FAIL-SAFE PERFORMANCE OR OPERATION. THIS SOFTWARE IS NOT FOR USE IN THE OPERATION OF AIRCRAFT NAVIGATION, NUCLEAR FACILITIES, OR COMMUNICATION SYSTEMS, WEAPONS SYSTEMS, DIRECT OR INDIRECT LIFE-SUPPORT SYSTEMS, AIR TRAFFIC CONTROL, OR ANY APPLICATION OR INSTALLATION WHERE FAILURE COULD RESULT IN DEATH, SEVERE PHYSICAL INJURY OR PROPERTY DAMAGE.

1. Definitions
(a) "Educational Version" means a version of the Software, so identified, for use by students and faculty of educational institutions only. "Home version" means a version of the Software, so identified, for use by individuals on a single computer at home only. Educational and Home Versions may not be used for, or distributed to any party for, any commercial purpose.
(b) Henceforward VirusBuster Ltd. means VirusBuster Ltd. and (where interpretable) its suppliers and licensors, if any.
(c) "Not For Resale (NFR) Version" means a version of the Software, so identified, to be used to review and evaluate the Software, only.
(d) "Software" means the VirusBuster Ltd. (R) VirusBuster(TM) software program supplied by VirusBuster Ltd. herewith, which may also include documentation, associated media, printed materials, and online and electronic documentation.

2. License
This EULA allows you to:
(a) Install and use the Software on a single computer; OR install and store the Software on a storage device, such as a network server, used only to run or install the Software on your other computers over an internal network, provided you have a license for each separate computer on which the Software is installed or run from the storage device. A license for the Software may not be shared or used concurrently on different computers.
(b) Educational and Home Version Only. If you have purchased a license for the Educational and/or the Home Version of the Software, then you may install or store the Software on a storage device, such as a network server, used only to run or install the Software on your other computers over an internal network for use by a total number of concurrent users not to exceed the number of user licenses you have been granted; provided, you agree to implement reasonable controls to ensure that your use of the Software does not exceed the number of licenses you have been granted. You agree that VirusBuster Ltd. may audit your use of the Software for compliance with the EULA at any time, upon reasonable notice.
(c) Make one copy of the Software in machine-readable form solely for backup purposes. You must reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the Software.

3. License Restrictions
(a) Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically transfer the Software from one computer to another or over a network.
(b) You may not decompile, reverse engineer, disassemble, or otherwise reduce the Software to a human-perceivable form.
(c) You may not sell, rent, lease, transfer or sublicense the Software.
(d) You may not modify the Software or create derivative works based upon the Software.
(e) You may not use the Software in automatic, semi-automatic or manual tools designed to create virus signatures, virus detection routines, any other data or code for detecting malicious code or data.
(f) In the event that you fail to comply with this EULA, VirusBuster Ltd. may terminate the license and you must destroy all copies of the Software.

4. Upgrades
If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license exchange basis. You agree by your installation and use of this copy of the Software to voluntarily terminate your earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or entity.

5. Ownership
The foregoing license gives you limited rights to use the Software. VirusBuster Ltd. and its suppliers retain all right, title and interest, including all copyrights, in and to the Software and all copies thereof. All rights not specifically granted in this EULA, including International Copyrights, are reserved by VirusBuster Ltd. and its suppliers.

6. LIMITED WARRANTY AND DISCLAIMER
(a) LIMITED WARRANTY. VirusBuster Ltd. warrants that, for a period of ninety (90) days from the date of delivery (as evidenced by a copy of your receipt) that the physical media on which the Software is furnished will be free from defects in materials and workmanship under normal use.
(b) NO OTHER WARRANTY. EXCEPT AS SET FORTH IN THE FOREGOING LIMITED WARRANTY, VirusBuster Ltd. AND ITS SUPPLIERS DISCLAIM ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, OR OTHERWISE INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. ALSO, THERE IS NO WARRANTY OF NONINFRINGEMENT, TITLE OR QUIET ENJOYMENT. IF APPLICABLE LAW IMPLIES ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, ALL SUCH WARRANTIES ARE LIMITED IN DURATION TO NINETY (90) DAYS FROM THE DATE OF DELIVERY. No verbal or written information or advice given by VirusBuster Ltd. its dealers, distributors, agents or employees shall create a warranty or in any way increase the scope of this warranty.

7. Exclusive Remedy
Your exclusive remedy under Section 6 is to return the Software to the place you acquired it, with a copy of your receipt and a description of the problem. VirusBuster Ltd. will use reasonable commercial efforts to supply you with a replacement copy of the Software that substantially conforms to the documentation, provide a replacement for defective media. VirusBuster Ltd. shall have no responsibility if the Software has been altered in any way, if the media has been damaged by accident, abuse or misapplication, or if the failure arises out of use of the Software with other than a recommended hardware configuration.

8. LIMITATION OF LIABILITY.
NEITHER VirusBuster Ltd. NOR ITS SUPPLIERS SHALL BE LIABLE TO YOU OR ANY THIRD PARTY FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS, LOSS OF PROFITS, BUSINESS INTERRUPTION OR THE LIKE), ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE OR THIS EULA BASED ON ANY THEORY OF LIABILITY INCLUDING BREACH OF CONTRACT, BREACH OF WARRANTY, TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE, EVEN IF VirusBuster Ltd. OR ITS REPRESENTATIVES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF A REMEDY SET FORTH HEREIN IS FOUND TO HAVE FAILED OF ITS ESSENTIAL PURPOSE.

9. Basis of Bargain
The Limited Warranty, Exclusive Remedies and Limited Liability set forth above are fundamental elements of the basis of the agreement between VirusBuster Ltd. and you. VirusBuster Ltd. would not be able to provide the Software on an economic basis without such limitations.

10. Consumer End Users Only
The limitations or exclusions of warranties and liability contained in this EULA do not affect or prejudice the statutory rights of a consumer, i.e., a person acquiring goods otherwise than in the course of a business.

11. General Provisions
The internal laws of Hungary shall govern this EULA. This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and supersedes all prior or contemporaneous agreements or understandings, whether oral or written. All questions concerning this EULA shall be directed to VirusBuster Ltd.

VirusBuster and VirusBuster logo are trademarks or registered trademarks of VirusBuster Ltd. in Hungary and/or other countries. Other marks are the properties of their respective owners.